I have been running for sometime now some flow charts within NodeRed and my Epic. I am collecting data from a webpage that converts text to number and then i send it to a Pac Write Node, then it goes to a floating variable within my Epic program.
I have the NodeRed setup as Localhost and i am using an admin key to communicate. Today, for some reason, it started giving me a PAC Error -401 Unable to Authorize Transaction error and i cant seem to budge from it.
Have you guys seen this before?
Sounds like the API key changed or the rights for the user changed.
How many PAC Nodes do you have? Are they all throwing that error or just the one?
I have seen (rarely, but have seen it) where one node will be throwing an error, but the others don’t. In this case a restart of Node-RED fixed it.
I thought that it was the API too, but I updated it and still had the problem.
And yes, all of them are having the same error. Ok how many nodes i have, I should be around 30 of them related to PaC.
Just to narrow down what might be going on, could you try creating a new admin user and use the new key, and see if that changes anything?
I created a brand new Nodered account with admin access and used that API and it didnt work either. I am still getting the 401 error.
Just to rule out, i added the IP address instead of the Localhost one and the error changed to Security Certificate Problem. So its definitely something with the local host communication.
Rebooted the PLC and Nodered, still not able to work with the PAC Nodes. Is upgrading the firmware an option?
What version are you on?
I’m wondering at this stage if its not worth raising an issue with our support group.
If i am not wrong, it was 3.4.1 (I think)
Im trying to do the firmware upgrade at this moment. And it been reloading for sometime now. Ill keep you posted to see if it works or not.
Team, confirming, with the firmware upgrade, i wasn’t able to get it to work again.
If there is anything else that i need to check, please reply.
At this point, best thing to do is to log a ticket with our support group:
It would be great if you could come back to this thread after they get it sorted and let the community know what the issue was.
Circling back, the support group requested me to reset the PLC in order for it to work again. Seems that did the trick.
However, the email node is not working on it. Ill keep you guys posted.
Are you using gmail?
If so, are you using an application specific password?
I blogged about it here: Google Apps ending access to less secure apps - are you ready?
No, what i mean is that the Node is not downloading at all. I sent the error image to Norm at the support group because he was helping me with the current issue.
The node just does not dowload.
Background, had to reset all and that also means NodeRed, so it was all cleared out.
Sounds like your EPIC or your PC has not got a valid gateway to the internet.
BOTH the EPIC and PC that is looking at the Node-RED editor have to have a valid gateway to the Internet to be able to install Nodes.
I think he is trying to load ver 2.0.0 of the email node that is not comatible with this build.
Before the reset he might have had 1.14.0
Confirmed with Node Red that the Node Version is in conflict with the current node red version that OPTO has.
Seems like i need to wait for the newest upgrade from OPTO. Do you guys have an idea when it would be rolling out?
Sorry, bit confused… Node-RED version conflicts with Node-RED version?
You can always install a specific version of a Node, but that wont work for Node-RED itself.
I updated to the latest version of node-red-contrib-modbus on my groov RIO and it seems to have broken the flex-write node?
Is there a way to install the older version of node-red-contrib-modbus again?
It was working fine with v5.13.1 of the modbus node, but I get the following error since installing v5.14.0.
Error: Modbus exception 4: Slave device failure (device reports internal error) at ModbusRTU._onReceive (/home/dev/.node-red/node_modules/modbus-serial/index.js:348:21) at TcpPor…
Right, I think he needs to install an older version of the email node like 1.14.0
Here is a link to that version of the email node:
After you download it use the Pallet Install Tab to upload it.
Anyone updating an Epic to 3.4.5 is going to lose this popular Node.
Beno, sorry i didnt specify it better. Ill try this out and keep you guys posted.