PAC Error -401 Unable to Authorize transaction

HI Norm

For some reason, the link that you attached is downloaded a zip file that does not contain the email node, just a series of folders that do not have the .tgz format. Then, i also tried to reach it through the directory attached and it says that i dont have access. Is there any other way that i can get the version?

thanks

@hcopsc1 That is strange. I just downloaded it again and emailed you a copy.
Let us know how you make out.

Just a reminder, when you get the email with the .tgz file, do not unzip it.
It installs as a .tgz from the Manage Pallet menu.

1 Like

Thanks Guys,

Got the email node back in.

thanks for your help !!

1 Like

Hi Norm,

Just started running with a New Epic and have the same problem now with the email node. I tried using the one that you previously sent, but wasnt able to make it work. Can you please give me a hand with this?


Did you get your email working?
I wonder if its giving you an error when you try and install the node?
Or is it not sending emails?
It could also be a network issue like your MQTT broker…
Need some more information…

Hi Beno

I am communicating with Norm on it. The last time he was able to help me.

On both questions, these are two separate Epics.

The email node problem is for the new Epic i fired up. The MQTT broker issue is on another Epic that was upgrades due to a Node Red failure.

To the original -401 error when using a PAC node. This can happen when any user is given the permission of “Dashboard UI” in the Node Red User Permissions settings in groov manage \Accounts\Users.
You need to either elevate them to Editor or set them as None, then re-start the Epic for the changes to take effect.
There is a ticket open on this so it can be addressed in a future firmware release.

1 Like

Hi Guys, I’m running into this same issue.

I have configured the certificate to match the IP address, and the API key is from an account that has Admin access to everything. I’ve made sure there are no firewall limitations with this, but I’m, still getting the same thing. Any help on this? I had the issue ‘Security Certificate Problem’ before installing the correct certificate, and now getting this error. I can’t seem to find many answers for this online either.

There is a fix coming for it in a firmware update ‘soon’.
For now, the work around is the post above yours from Norm.
Get the user permissions set right, restart and you should be good.

Hi Ben, I have tried a few different things, still not working. I made a dedicated ‘nodered’ user account, gave it Editor permissions, gave it None permissions, restarted Node-RED after each attempt and still nothing. Are there any other workarounds?

I have it working here with Admin, so something else must be in play.
You’re just trying to write a value to a PAC Control variable on the same EPIC as Node-RED is running?

You have the write node set to localhost?

image

Is the final permission setting for your nodred account set to Editor?
It will need to be. You may also want to not fire both PAC Nodes at the same time. Try putting them in series.

Only coming back around to this error now - I can confirm the permissions for my nodered account are set Editor. I have adjusted to write to one node for now just for testing:

image

Similarly to OP I changed the Address to the devices IP Address and it came up with a security certificate error, then changing it back to ‘localhost’ returned the -401 error again. I’m not sure if it’s worth noting however there is a little green status message which says “Determining device type” very very briefly before returning the error.

I have regenerated the API Key a few times but that did not do anything for me.

image

EDIT: Thought I would add this config screen too
image

In PAC Control, does Current_Alarm have public write permissions?

It does, it has public read/write capability.

Do you have any accounts on your EPIC that are assigned the Node-RED Dashboard UI role? That’s the issue that was fixed in GRV-EPIC 3.6.0: if anything is using the Dashboard UI permission, the PAC REST API stops working.

https://www.opto22.com/support/resources-tools/knowledgebase/kb90739