For some reason, the link that you attached is downloaded a zip file that does not contain the email node, just a series of folders that do not have the .tgz format. Then, i also tried to reach it through the directory attached and it says that i dont have access. Is there any other way that i can get the version?
Just started running with a New Epic and have the same problem now with the email node. I tried using the one that you previously sent, but wasnt able to make it work. Can you please give me a hand with this?
Did you get your email working?
I wonder if its giving you an error when you try and install the node?
Or is it not sending emails?
It could also be a network issue like your MQTT broker…
Need some more information…
To the original -401 error when using a PAC node. This can happen when any user is given the permission of “Dashboard UI” in the Node Red User Permissions settings in groov manage \Accounts\Users.
You need to either elevate them to Editor or set them as None, then re-start the Epic for the changes to take effect.
There is a ticket open on this so it can be addressed in a future firmware release.
I have configured the certificate to match the IP address, and the API key is from an account that has Admin access to everything. I’ve made sure there are no firewall limitations with this, but I’m, still getting the same thing. Any help on this? I had the issue ‘Security Certificate Problem’ before installing the correct certificate, and now getting this error. I can’t seem to find many answers for this online either.
There is a fix coming for it in a firmware update ‘soon’.
For now, the work around is the post above yours from Norm.
Get the user permissions set right, restart and you should be good.
Hi Ben, I have tried a few different things, still not working. I made a dedicated ‘nodered’ user account, gave it Editor permissions, gave it None permissions, restarted Node-RED after each attempt and still nothing. Are there any other workarounds?
I have it working here with Admin, so something else must be in play.
You’re just trying to write a value to a PAC Control variable on the same EPIC as Node-RED is running?
Is the final permission setting for your nodred account set to Editor?
It will need to be. You may also want to not fire both PAC Nodes at the same time. Try putting them in series.
Only coming back around to this error now - I can confirm the permissions for my nodered account are set Editor. I have adjusted to write to one node for now just for testing:
Similarly to OP I changed the Address to the devices IP Address and it came up with a security certificate error, then changing it back to ‘localhost’ returned the -401 error again. I’m not sure if it’s worth noting however there is a little green status message which says “Determining device type” very very briefly before returning the error.
Do you have any accounts on your EPIC that are assigned the Node-RED Dashboard UI role? That’s the issue that was fixed in GRV-EPIC 3.6.0: if anything is using the Dashboard UI permission, the PAC REST API stops working.