Install older version/specific version of a node-red node?

I updated to the latest version of node-red-contrib-modbus on my groov RIO and it seems to have broken the flex-write node?

Is there a way to install the older version of node-red-contrib-modbus again?

It was working fine with v5.13.1 of the modbus node, but I get the following error since installing v5.14.0.

Error: Modbus exception 4: Slave device failure (device reports internal error) at ModbusRTU._onReceive (/home/dev/.node-red/node_modules/modbus-serial/index.js:348:21) at TcpPort.emit (events.js:198:13) at Socket.<anonymous> (/home/dev/.node-red/node_modules/modbus-serial/ports/tcpport.js:77:20) at Socket.emit (events.js:198:13) at addChunk (_stream_readable.js:288:12) at readableAddChunk (_stream_readable.js:269:11) at Socket.Readable.push (_stream_readable.js:224:10) at TCP.onStreamRead [as onread] (internal/stream_base_commons.js:94:17)

Yes.
If you don’t have shell access on your RIO, you will need to get a shell license.
https://www.opto22.com/products/product-container/groov-lic-shell
Apply it to your RIO and install PuTTY (if you are on Widows).

First, remove the node that is not working via the ‘Manage Pallet’ menu option.
Then restart Node-RED via the groov Manage menu.
That will flush the old non-working version.
Then from shell…
Log in to your RIO.
Type the following commands

sudo su
cd /home/dev/.node-red
npm install node-red-name-of-node@n.n.n

Where n.n.n is the version you want to install.

Lets know how you get on.

3 Likes

Actually, I just figured out that the error was caused because the PLC wasn’t in a “ready” state… so the updated v5.14.0 node-red-contrib-modbus node is working fine.

But thanks for the instructions :+1:

2 Likes