PAC Error -401 Unable to Authorize transaction

Are you using gmail?
If so, are you using an application specific password?
I blogged about it here: Google Apps ending access to less secure apps - are you ready?

No, what i mean is that the Node is not downloading at all. I sent the error image to Norm at the support group because he was helping me with the current issue.

The node just does not dowload.

  • Background, had to reset all and that also means NodeRed, so it was all cleared out.

Sounds like your EPIC or your PC has not got a valid gateway to the internet.
BOTH the EPIC and PC that is looking at the Node-RED editor have to have a valid gateway to the Internet to be able to install Nodes.

I think he is trying to load ver 2.0.0 of the email node that is not comatible with this build.
Before the reset he might have had 1.14.0

Hi Guys,

Confirmed with Node Red that the Node Version is in conflict with the current node red version that OPTO has.

Seems like i need to wait for the newest upgrade from OPTO. Do you guys have an idea when it would be rolling out?

Sorry, bit confused… Node-RED version conflicts with Node-RED version?

You can always install a specific version of a Node, but that wont work for Node-RED itself.

Right, I think he needs to install an older version of the email node like 1.14.0
Here is a link to that version of the email node:
After you download it use the Pallet Install Tab to upload it.
Anyone updating an Epic to 3.4.5 is going to lose this popular Node.

thanks Norm

Beno, sorry i didnt specify it better. Ill try this out and keep you guys posted.

thanks always!

HI Norm

For some reason, the link that you attached is downloaded a zip file that does not contain the email node, just a series of folders that do not have the .tgz format. Then, i also tried to reach it through the directory attached and it says that i dont have access. Is there any other way that i can get the version?


@hcopsc1 That is strange. I just downloaded it again and emailed you a copy.
Let us know how you make out.

Just a reminder, when you get the email with the .tgz file, do not unzip it.
It installs as a .tgz from the Manage Pallet menu.

1 Like

Thanks Guys,

Got the email node back in.

thanks for your help !!

1 Like

Hi Norm,

Just started running with a New Epic and have the same problem now with the email node. I tried using the one that you previously sent, but wasnt able to make it work. Can you please give me a hand with this?

Did you get your email working?
I wonder if its giving you an error when you try and install the node?
Or is it not sending emails?
It could also be a network issue like your MQTT broker…
Need some more information…

Hi Beno

I am communicating with Norm on it. The last time he was able to help me.

On both questions, these are two separate Epics.

The email node problem is for the new Epic i fired up. The MQTT broker issue is on another Epic that was upgrades due to a Node Red failure.

To the original -401 error when using a PAC node. This can happen when any user is given the permission of “Dashboard UI” in the Node Red User Permissions settings in groov manage \Accounts\Users.
You need to either elevate them to Editor or set them as None, then re-start the Epic for the changes to take effect.
There is a ticket open on this so it can be addressed in a future firmware release.

1 Like

Hi Guys, I’m running into this same issue.

I have configured the certificate to match the IP address, and the API key is from an account that has Admin access to everything. I’ve made sure there are no firewall limitations with this, but I’m, still getting the same thing. Any help on this? I had the issue ‘Security Certificate Problem’ before installing the correct certificate, and now getting this error. I can’t seem to find many answers for this online either.

There is a fix coming for it in a firmware update ‘soon’.
For now, the work around is the post above yours from Norm.
Get the user permissions set right, restart and you should be good.

Hi Ben, I have tried a few different things, still not working. I made a dedicated ‘nodered’ user account, gave it Editor permissions, gave it None permissions, restarted Node-RED after each attempt and still nothing. Are there any other workarounds?