Cannot login/find hostname groov EPIC

Hi everyone,

I’m currently trying to login to EPIC via browser but had no success. I tried the hostname and also the static IP (assigned via the onscreen display), for the IP it says:

This site can’t be reached took too long to respond.

for the hostname it says:

This site can’t be reached

opto-04-xx-xx ’s server IP address could not be found.

I tried groov Find and that didnt work either.
Ran network diagnostic and it says “Ethernet” doesnt have a valid IP configuration.

My groov RIO is doing the same thing. I tried on different browsers, different laptops but no luck so far.

Thanks in advance for any help.


Hi Aaron. Welcome to the Opto22 forums!

Ok, so this sounds ‘fun’…

groovFind works on your computer, not on the EPIC. So clearly there is an issue with the network on the EPIC vs the PC.
What Ethernet port are you jacked into?
I’d be using Eth0, the top one for starters…

Hi Beno, yes I’m using Eth0.

Great start.
Ok, can you please grab us a phone photo of the Network → Status from the touch screen on the EPIC…
This is what mine looks like (from a PC browser - we will get there with yours!).


We need to see if its picked up a gateway and DNS server.
Also if could check your computer DOS prompt IP address and make sure your PC and EPIC are on the same subnet, DNS and Gateway.


Hi Beno,

Great news. I got them both working. Thanks a lot for your help.
I do have another problem. I used PAC Control Basic to write a strategy and selected the RIO as the I/O Units. When I debug it says:

Ethernet socket error.Socket is not connected
Code: -10057

I’m not sure where to go from here.
Thanks, Aaron.

Glad you got up and running, what was the issue and the fix?
It would be helpful for others to know.

Looks like the first post here has the answer to your -10057 error (This is a great example of why posting solutions is helpful for everyone - a search will find the answer).

Hi Beno,

Since they were setup by someone else in the department, all I had to do was reset them and that’s was it.

In regard to the error -10057 I did do a search on the forum before posting and followed the advice but I didn’t have any luck.

Edit: I can access groov Manage via browser so the connection is made. I followed this thread “Socket error while downloading to PAC Sim
but realised I dont have SoftPAC Monitor because mine is the basic version.

groov Manage uses a different port from PAC Control.
Sounds like you are in a very locked-down network.
The posts you searched and read have the answer I suspect.

Can you please test the network on port 22001 from the EPIC to the RIO via groov Manage network tools.

I think you will start to find the -10057 error there.

Beno, I’m just connecting the RIO to the laptop at this stage. I’m not connecting the EPIC to the RIO.?

Fully understood.
Hence if you check the port connectivity via groov Manage network diagnostics you will start to find why PAC Control can not connect to the RIO from the EPIC.

Oh, Ah. Ok, Your edit changes things.
I thought you had a time out (-10057) from the EPIC to the RIO in PAC Control. It seems that is not the case.

Can you please draw out a diagram and photosnap it on a phone to here? We are not sure of your network config or where things are timing out.

I don’t understand how your laptop can have an error -10057.

Sorry for not being clearer before. What kind of diagrams are you looking for?

Could a missing license file be responsible for this?

Ok, so you are running SoftPAC on the laptop?
You have the RIO as remote IO in a strategy and you are getting a time out (-10057) on the laptop control strategy.
Right. Well in this case, we need to check the firewall on the laptop…

I’m not running SoftPAC as the PAC Control Basic does not come with SoftPAC. Regarding the firewall. I have already turned it off.

Do you have the RIO in the control engines section of PAC Control? If so, that won’t work as the RIO does not have a control engine in it. It can only be listed in the IO unit section of PAC Control which is further down the strategy tree.

You can only use an EPIC or PAC Controller as your control engine. The RIO can be used for IO only in PAC Control.

Hi Philip. Ahh that could be the reason. I went ahead and deleted the control engine, now when I press Debug it says:

Please select a control engine prior to debugging.

Ok, so your not running PAC Control on the laptop as shown in the diagram, so there must be an EPIC that is not shown.
You need to configure the EPIC in PAC Control on the laptop as the controller.
In the strategy that is downloaded from the laptop to the EPIC you need configure the RIO only as an IO unit in the strategy, not a controller as Philip pointed out.

Thank you both for pointing that out. I was under the impression that the RIO has its own control engine. My bad.

One more thing if you could help me out. I tried to download groov I/O in Node-Red but I coudnt. The laptop connects to the EPIC via ethernet and has WIFI. I can access to groov Manage and thent to Node-RED, search was OK too. It says failed to install. I suppose this is a network problem but I’m not sure where to start.

Make sure the EPIC has the gateway and DNS server for your network setup on it. The EPIC needs to be able to access the internet and resolve hostnames (DNS) to download nodes.