Serial 485 converter


there is a way to install the drivers for a converter that is not recognized. I bought a fairly expensive converter but the Groov RIO doesn’t detect it. What I can do?

Hi Gustavo, is it one of these converters? If not, I’m afraid you may be out of luck for the time being. We may expand later to add more devices, but adding one on your own (that isn’t from this list) will not be possible at this time. Can you share which device you purchased? image

the model I have is the moxa uport 1150

and it has linux drivers.

Thanks for the link. Unfortunately they don’t seem to list/mention what driver they use.
RIO (and EPIC) support authentic FTDI driver chip.

More information about RIO USB serial devices can be found in this thread:

Just want to chime in my 2 cents on this one too as I’ve recently been playing with this. Ben is absolutely correct on the driver chip. I first (accidentally) ordered a USB to Serial converter that had a CAN2012 chip. While it worked great from a Windows PC, and even showed up as recognized on my EPIC, that’s where it stopped. I went back and ordered the identical adaptor but with an FTDI chip and it worked perfectly both on an EPIC and on a RIO.