RIO IsIOUnitCommEnabled not working?

I have a strategy with several RIOs. Just recently all the IO from the RIO was frozen in the HMI. In Debug, when I click on one of the RIO IO units it has an error:

I/O Unit not enabled. Previous communication failure may have disabled the unit automatically.

I have an IO_Enabler chart on this strategy and the IsIOUnitCommEnabled function is returning true even with that error. Is this supposed to work like this? How do I re-enable a RIO through the strategy after a communications failure?

It sounds like this:
https://www.opto22.com/support/resources-tools/knowledgebase/kb89056
But cant be… you would be running better than 2.0?

Will dig into it a bit more tomorrow.

These (RIOs) are 2.0.2-b.199, so must be something different.

The PR1 that the strategy is running in is using 3.0.0-b.62

Have you heard anything on this? We are still seeing this issue.

Do your remote RIO’s use host names in the PAC Control strategy?

https://www.opto22.com/support/resources-tools/knowledgebase/kb89421

No, they are using IP addresses. I need to setup something on my test bench to reproduce and troubleshoot this, just haven’t had the time yet.

I have been unable to reproduce this on my bench where the “I/O Unit not enabled” message appears and Enable comm is yes. I’m at a loss to how this is happening, any insight or help is appreciated.

No problem. I always appreciate your help Philip.
I put a RIO on an EPIC with PAC Control 10.3x (the release version - for once) and am kicking at it.
So far, very quick test before I got pulled away late this afternoon, it was working as expected, but I am not going to move on just yet.
Anyway, said all that to ask, is that the same sort of set up you are using? RIO as IO from EPIC?

Yes, the strategy is running on a PR1 with RIO and EB1s for IO units. The RIOs and EB1s are connected through various point to point wireless networks and occasionally lose connection (I assume). The IO enabler chart starts the EB1s back up, but not the RIOs.

Do you know if there is a way to check in the strategy whatever PAC Control is checking to generate the “I/O Unit is not enabled.” error message? If I could check that, then I could have the strategy disable and re-enable communications to automatically bring it back on line as a work around.

The issue with the IO enabler chart is it only looks at IsIOUnitCommEnabled which is returning true in this case (even though it probably shouldn’t).