Pac control groov rio io error


Have not opened a ticket in hope of faster response here. I have “one of those” problems in pac control.
How this “bug” came about happened in the following manner:

I created a RIO IO unit and then opened configure to create my input IO point.
This worked correctly (why is the method for adding IO on the RIO so wonky? I am able to paste the same name multiple times over the span on the unit)

Once I went and tried to change the name of the IO point something strange happened:

I can now not delete the old RIO IO unit, as soon as I click on the Channels folder I get the error above endlessly until pac control crashes.

I tried to recreate the IO point with the same name in another RIO unit and then the same happens.
So it seems like it does not like this particular name I am using, I can’t see the IO point on the RIO and I cannot delete the RIO unit from my strat as it thinks it’s referenced somewhere. That particular channel is empty (see below) but as soon as the mouse hovers over the empty space the endless improper argument error appears.

Please help, more pics below:

Just to add to this post. I did a test now in PAC CONTROL and I am able to create IO points with the same name. Surely this should not be allowed? I think this may be the cause of the error above. For example, if I do a name changed on a RIO IO point and it happens to be the same as another RIO IO point I think we will get the error/bug from the original post.

same io name

See my reply to this error that was asked yesterday morning:

thanks but the issues seem somewhat related and unrelated…

Mine is specific to the RIO IO and setting up thereof.

I removed all versions of PAC on my machine (had two 9.5 and 10.3) and then reinstalled the latest. Same problem

Should I mail support ?

In Configure | Options | Advanced tab there is a check box for allowing points and variables to be deleted that have references. Not sure if that will work for IO units, but it is worth a shot to see if you can delete the IO unit.

Thanks Philip. This did not work. Even though I ticked that option it still tells me I cannot delete IO with reference greater than zero