PAC Control 10.2 undefined command on new computer

I’m working on a new project in PAC Control Basic 10.2 that I’ve been developing on my laptop. I’m fighting PAC Display on an issue and wanted to test the project on my desktop. I’ve transferred the PAC Control project archive to my desktop, but when I go to download (this is an EPIC PR1 project, but I am testing locally in SoftPAC), I get the following ‘Undefined Command’ error during download:


It seems like the IO unit data is not getting “compiled” into the project. Is there a setting or something that I am missing to get this to work? I’ve tried adding an additional IO point, but that didn’t do anything.

Found the issue, I had an older build 10.2a on my desktop and 10.2e on my laptop. The desktop didn’t recognize some of the EPIC modules in the IO unit with that build. It said unknown analog input or something like that in the IO unit list.

yip, had that same error. Was a rogue IO unit that crept in on the strat

I had a problem with converting from 10.1 to 10.3, Pac Control messed with several variables by attaching them to different variables and it really had a problem with an analog 2 channel output tag.

Has their been a resolution to this Error? We just ran into it using PAC Project Pro on Win7 & Win10 laptops, which we use all the time to download R2 Controllers.
Thanks Dave

Seems that the third post above yours has the solution Dave.

Yep, I read that. We’re not using an Epic setup, we’re using SNAP with R2 controllers. this is the first time seeing this. And yes, we’re still working in the PAC Project 9.0 world, we plan on moving into the ‘real’ Opto world, but we have so many legacy systems in the field its hard to know when to make the conversion. I have more information on this, but not sure if this is the right place for it. It may be best to head on over to Support?

Apologies in advance for resurrecting a very old thread, but I encountered a similar error, again while downloading to a groovEPIC controller, for a very different reason. I wanted to share what ended up being the problem:

One of the charts in my strategy used a subroutine, and there was a type mismatch between the subroutine parameters and the calling code in the chart. The subroutine was looking for a String Literal, and and calling code was sending a String variable. For whatever reason, the compiler didn’t catch this, and it was causing an undecipherable ‘Undefined Command’ error (somewhat similar to what’s shown above) when trying to download the strategy.

1 Like

That should be perfectly okay, unless you meant the other way around.

All I know is that the problem went away when I changed the parameter list of the subroutine to expecting the string variable that was being sent to it. Obviously the compiler agrees with you; otherwise, it would have flagged this error (and probably given me a more useful error message). As it was, I had to export & delete charts until the download error went away, then re-import the charts and go block by block to find the offending statements. I’m just glad I finally found it, because this particular problem hasn’t been covered a lot in these forums.

Not sure if this would have helped in your case, but when I have encountered strange errors after downloading, I will do a “Compile All” and then download and many times it goes away.

I actually do this by habit now, because sometimes the strange error like this ends up clearing the strategy and all persistent variables which can be a good test of patience.

Yeah, I did the “Compile All” more times than I can count, along with (1) restarting the controller, (2) shutting down and restarting the PAC Control software, (3) fiddling with the “init.txt” initialization file, and a few other things in my desperation. This whole strategy is converted from a decades-old “Factory Floor” strategy that’s being brought into the 21st century, so little issues like this have been common.

This error during a Strategy download to an R2 Controller has reared its head once more. I have not seen this for some time. The Strategy is one that we have been using for over a year and have downloaded to many R2 Controllers without incident. However, the laptop in use was running Win11 with an older version of PAC Project Pro, the Strategy was compiled several times with no errors.
Any thoughts?

Compiling on the PC just ensures that the strategy itself is error free.
The issue you are seeing is that the PAC R2 firmware does not understand something in the strategy.
For best results you need to be running the latest firmware and the latest PAC Control, but I know you cant do that, so you will have to debug it by finding what firmware version you need for that strategy.

(The reason you have been running fine for years is because the PAC Control version and PAC firmware version agreed, this time, on this controller, it does not).


Thanks, this all makes perfect sense. We are getting closer to migrating the the latest version of Strategy, but for now we’ll have to find the ‘prefect match’. We do not seem to have any troubles with the Strategy (v9.0’s) with the R2 controllers coming with r10.4.
I currently have r10.3, but cannot find Opto’s ftp site to download r10.4, do you have a link I can try.

Possibly a related issue, maybe not. When I was attempting in install firmware r10.3 using PAC Manager 9.0, 9.6, 10.1, 10.2 with Win10, Win7 & Win11 pc’s. I keep running into the issue "… Firmware update complete, but could restart could not be confirmed. " If I power cycle the controller, it does not work, it reverts to the bridge firmware version.
Maybe I should open a service ticket?
We turned security on the FTP server some time back, so you might be having issues due to that.
Nice thread here on getting connected:


I was able to access the FTP site and downloaded the latest R2 firmware. I found that PAC Manager 9.6 works on updating the firmware to the R2 controllers without a hitch. I know understand about “what version combination” works for our current situation.

Thanks, Dave

1 Like