Latest node-red-contrib-modbus is not working - Fix, needs ssh


#1

The latest version of Modbus package (node-red-contrib-modbus) is not working. The Modbus-tcp package does work, but doesn’t do well with having multiple connections to multiple slaves.

Most people will install node-red-contrib-modbus. With some research and testing, it doesn’t matter what firmware release you are using for the EPIC. It is module issue.
More info: https://github.com/biancode/node-red-contrib-modbus/issues/134

To fix it, you will need shell access.

Once you login to your EPIC via SSH:
Use the following command:

cd /home/dev/.node-red/node_modules
sudo npm install -g node-red-contrib-modbus@4.1.1
Enter your password, and it will install the previous working version.
Restart Node-Red (https://your.ip/manage/local/node-red), Disable, Enable

Now you have a working version of the modbus client.

Dan