Groov Email not Working


#1

I’m trying to get Groov to send an email alert using a Gmail account. I’ve tried it on three different Groov boxes at three separate locations. One worked fine. The second I had to tweak the Gmail security settings to get it to work. The third doesn’t work at all no matter what I try.

Keep in mind that all the settings are identical on all three boxes and they’re all using the same Gmail account. There are no outbound firewall restrictions. The Internet connection is provided by identical Cradlepoint cellular modems in three separate geographical locations but with the same carrier, Verizon.

I was able to get the third one to work using a mail server that I support, not Gmail, but I had to setup relaying which is a big no-no so that’s not a viable solution. It does however, demonstrate that the Groov is capable of sending email.

Anybody have any thoughts as to why this won’t work?

Thanks,

Dave


#2

Go to https://accounts.google.com/b/0/DisplayUnlockCaptcha and click continue and then try from the non-working groov again and see if it works.


#3

Yeah, gmail is getting harder to work with…And not just for groov… Check out my post here for hints on how I got a command line app to work with gmail’ Bandwidth monitoring
(Just review the first 3 steps for groov, the rest is application specific).

You may find the right combination of ‘unblocks’ you need to allow it to work.
(Its really worth setting up a ‘low security’ gmail account just for this sort of thing).


#4

I agree - and allowing access to corporate e-mail is challenging as well sometimes. I think it is only a matter of time before it all goes mandatory 2 factor.

I’ve been testing out Amazon AWS simple notification service - using it in Node-red to send alert e-mails and SMS messages. It nicely decouples the sending of the alert and the list of subscribers as well. Now that we can do TLS on comm handles, I have to see if I can get it working directly in a PAC as well.


#5

Thanks for all the replies. The thing is, I did all that before I posted on the forum. What I don’t understand is we’re dealing with a single Gmail account. Why does it work on one Groov box and not another with the exact same settings?


#6

Not sure why it would be blocked - are the groov’s at different locations? Is there any security related email in the gmail inbox for the account that will help you troubleshoot?

Can’t you setup a specific account for groov to use with authenticated SMTP on your mail server? You shouldn’t have to run an open relay.


#7

Have you checked the logs on the box that it’s not working on? Or when testing, what error message do you see down here?


#8

I will try to answer all the replies.

The mail server i was relaying from is not one that belongs to our company so I can’t set up a specific account on that server. That would be too easy.

These Groov boxes are each on a single LAN with only two or three tcp/ip devices. Each one connects to the Internet through the exact same model Cradlepoint cellular modem using a Verizon cellular account.

Here is the current error I’m getting when I send a test email on the one that doesn’t work:

534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbsX 534-5.7.14 yWMf-N6tR42X4vUzmJuOPdDy2apu1JgBsEZMMMrnT4lv434YRHGial81cmogRkVQyOqjxm 534-5.7.14 r-62SwVTRFBOHqsugqeIEZR6Wwvnp2P_lRMcxw9lPZdR0uZVu_TzrPvlEUY0Be5clnY3XF 534-5.7.14 SQvcE0AkA0SSS8117G869FzteS0_HJCI2AgnzCn58S_656zAD83A1VQMSSkkXSuW9j3Ven 534-5.7.14 6VEIu6sqHTCFfn3qxEldbQCZVo8s8> Please log in via your web browser and 534-5.7.14 then try again. 534-5.7.14 Learn more at 534 5.7.14 https://support.google.com/mail/answer/78754 e71sm3584908pfk.55 - gsmtp

That’s a two-step verification error I’m presuming. However, using another Groov box with the EXACT same email configuration, using the EXACT same Gmail account, I can send a test email just fine.

Here is the config for the one that doesn’t work.

Here is the config for the one that does. The blacked email addresses are the same.


#9

Looks like gmail is getting even pickier about security, and even more device-specific. When I tried doing something similar, gmail gave me a “Did you sign in on this device?” and a “Someone has your password” (where I had to click “Yes, that was me” a couple of places).

Google claimed the device “using my password” was in Tacoma even though this particular groov Box is near Paso Robles, CA.

I also used port 25 and unchecked the “Allowed untrusted certificates” box in groov, but I’m not sure if that matters.


#10

That looks like Google just deciding you’re trying to send from the same email account from too many places. They don’t like their service being used this way.

You can try contacting Google to see if they’ll allow it through, but you may simply need to use another service.


#11

Maybe setting up a specific App password for each groov will work?

https://support.google.com/accounts/answer/185833?hl=en


#12

I gave up. Downloaded a free SMTP server called MailEnable, bought a new domain name, put it on a box I already had, pointed my MX record to it, problem solved. :-} Did all of this is a third of the time I’ve spent trying to get Gmail to work.

Maybe someone else will have better luck than I did with Gmail.

Thanks for all your help.

Dave


#14

Generating an App Password worked for our company, as philip shared above.