Epic Nodered Manage Palette Failed To Load Catalogue

I have an Epic that I can’t add nodes to Nodered. When I go to Manage Palette I get a “Failed To Load Catalogue. Check the browser console for more information”

My browser console shows the error: ERR_NAME_NOT_RESOLVED for: (without the quotes)
" https://catalogue.nodered.org/catalogue.json " (see image below)

This Epic is normally not connected to the internet so I ran a temporary Ethernet cable from a nearby router to eth1 and set it for dhcp.
Eth1 has Gateway Order and DNS Order set to 1.
I can successfully ping host names like google and yahoo, so DNS seems to be working. It can also ping registry,npmjs,org and catalogue,nodered,org
(ping image below)

I can also create a very simple Nodered flow with the mqtt in Node and it successfully subscribes to active topics using a mqtt broker that is in the cloud, referencing the broker by host name and not IP address.

I was considering firewall settings in the router. I don’t have access to it or its settings or anyone who knows anything about it. So I made my phone a hotspot and with an Ethernet Extender connected the Epic’s eth1 port to it. Same result. I can ping the Internet using names, but Manage Palette still fails.

The Epic is running firmware 3.2.0-b.44

I’ve tried several additional DNS Severs (,,
I’ve power cycled the Epic.


Browser Console showing error:

Dave, I seem to recall this error in the past, but cant find a post on it.
Please take a look at the Node-RED log in groov Manage and lets know what it says. There might be a clue there.

EDIT. Also double check your groov Manage network settings page.
This guy had everything right but was not getting a gatway IP address:

Not much in the Epic’s Node-RED Console Log.

I just started working on a very small NodeRed flow to move a few Ignition Tags into the PAC Controller. Before that, there has been no NodeRed code on this Epic.

When I attempt to Manage the Palette, the error pops up immediately, almost as it if didn’t try. Rechecking to log after the error, there is nothing new.
Is there another log I could check?

Hows the groov Manage network settings look?
Screenshot of them would be helpful.

Network Settings

Ping results:

Ok, the gateway is pointing to Eth1, the untrusted network.
What’s the firewall settings for Eht1? Its the most restricted by default. Have you adjust them to allow HTTPS traffic on Eth1?

Why do both interfaces have gateways configured?

Eth1 has the firewall enable for groov Epic 443, OptoMMP 2001, PAC Controller 22001, Ignition Edge and Designer. They normally use eth1 internally and I just need to set it be the untrusted network to apply an Ignition license and download the ignition and opto nodes. Otherwise it normally has a static IP and connects to another piece of equipment on a different subnet.

eth0 has the Gateway pointed to its router, which is not on the internet. That router has some more opto and provides a wireless network for nearby groov mobile users.

Can you temporarily remove the gateway from eth0 and then try to update your nodes?

No help. Same thing.

Failed to load node catalogue Error

Does ping to the outside world still work?

Ping to the outside world still works.

I’m setting this aside for now. There is a backup/spare epic that I will take with me and try in the office on my own network. There is no question the Manage Palette works, so its a matter of finding out what the issue is. I will report back.
Thank you very much for the help.

Caveat: I’m not a Node-RED guy at all, but I am a web guy: that GET error appearing in the JavaScript console means that the request originated from within your browser, not from within Node-RED’s server process. So it’s not failing to resolve on your EPIC, it’s failing to resolve from whatever computer your web browser is running on.

Does your workstation have access to the public internet?


YES! I knew @torchard and I had seen this error before and BOTH of us had totally forgotten, its not just the EPIC that needs to the see the Node-RED catalog, but also the PC… far out… Thanks @Jonathan_Fischer

@dp_engsberg BOTH the PC that has Node-RED loaded AND the EPIC need to be on the same gateway.

1 Like

The workstation did not have public access! I’ve been switch wireless network between the internet and the controls network.
So I just ran a long ethernet cable into the switch in the control panel so that my laptop can be connect to both the controls and internet.
So is the lesson here that your PC must also have internet access always? That the Epic’s access isn’t enough? If someone understands why that is the case I love to know why.

1 Like

As we say in Australia… its a twofa. You need both the EPIC running Node-RED to get the catalog, but some of it is also loaded in the browser that is viewing Node-RED.
I have never locked it down to knowing which parts of the palette are loaded where, its just a ‘rule’ that Terry and I found (with another customer in your exact situation). I’m really sorry Dave for the lost time. Terry and I were chatting offline a bunch and just could not put our fingers on it.

I am now wondering what other keywords I can put into this thread to make sure it gets found in the future.

1 Like