Vertical Scroll Bar


#1

I’ve noticed that when creating a page in Groov Build that a vertical scroll bar is included on the Groov View screen whether it is necessary or not. (I ran a test and put one small item in the middle of the screen and the right side vertical scroll bar still appeared.) Is there a away to have it only appear when needed? Thanks.


#2

Which browser/operating system are you using? I’m on macOS 99.9999% of the time, so scroll bars are typically hidden unless I’m actively scrolling. I could easily just have missed it.

Glancing quickly, it looks like we might be deliberately setting the page container to be the size of the browser window + the size of the navigation bar at the top, which would explain why there’s a scrollbar.


#3

I see this, too, in Windows on Chrome and Firefox.


#4

I mainly use Chrome, so this is only for that browser…

Go to the Chrome URL bar and type in chrome://flags/#overlay-scroll bars
Scroll down to the bit where it says ‘Overlay Scrollbars’ and set it to ‘Enabled’.
Relaunch Chrome and you should be scroll bar free (as long as you don’t build your groov screen bigger than the browser window).


#5

I’m marking this down as an issue to be addressed in the next release. No idea when that’ll be out though, sorry!