Using a USB hub in PAC Control

I’m using a groov EPIC (3.4.4-b.128) and PAC Control Basic (R10.4C). My goal is to use a powered USB hub and several USB to serial adaptors in order to imitate a unit in the field (that’s using a GRV-CSERI-4 Four channel communication module).

The 1700_PAC_Control_Users_Guide says on page 292:


Format 1:
The format for the communication parameters is:
ser:<port number>,<baud rate>,<parity>,<data bits>,<stop bits>

Format 2:
With this format, you prefix the parameter values with keywords. This format:
The format for the communication parameters is:
• For groov serial modules:
@<channel name>:<keyword>=<value>,=<value>,…
Note that you do not specify the port number.
• For groov EPIC processors or SNAP PAC controllers:

The original configuration handle uses the following format:
This works properly (Using format 2).

But in order to get the USB to serial adapter working correctly, I had to use:
as shown in the Using a Serial to USB Converter with EPIC video (Thanks for providing that!)

I’ve tried using Format 2, but that doesn’t seem to work with the USB ports.

When I’m using a hub, I can see the adaptor plugged into the hub as /dev/ttySer0.1 (Port number 0.1) [in groovManage system → Serial Devices]

If I were able to use Format 2, I could simply add port=0.1 to the parameter list - but as I mentioned before, I seem to only be able to use Format 1 - How do I proceed?

ser:0,baud=9600,data=8,parity=n,rts-cts=1,stop=1 (No hub, using port 0) - doesn’t work.
ser:0,9600,n,8,1 (No hub, using port 0) - works

ser:0,baud=9600,data=8,parity=n,port=0.1 (Using hub port 1) - doesn’t work
ser:0.1,9600,n,8,1 (Using hub port 1) - doesn’t work (Invalid Connection - Not opened.)

Thanks for any help anyone can throw my way!



1 Like

That was the magic! Thanks a bunch.
(I thought I tried everything :face_with_raised_eyebrow:)