Use Terminal app (PuTTY) to communicate to R1 Serial Port 0?

Hey! I have an RS-232 device (I know…) connected to the Serial port 0 on the SNAP-PAC-R1 controller, and I’m having trouble (I know!) getting it to communicate to PAC Control. I’ve done serial comms a billion times before, and I’m using code that used to work when they had this device connected to a SNAP-SCM-232 module, so it should work.

In the past, I’ve had success bypassing the Opto serial code and figuring out the communication using a Terminal program. I used to use HyperTerminal, and now I’ve been using PuTTY. I’m not great at this. On the SCM-232 module, you just use the IP address of the R1 with the port that corresponds to the module’s position on the rack and if it’s on port A or B (e.g. 22500). Does anyone know how to set this up with the R1 on-board serial port? I can’t find a reference to the on-board serial port 0 number.

Thanks!

You will only be able to access the built-in serial port through PAC Control on the R1. It doesn’t have a corresponding TCP port #. The comm handle will be a serial comm handle instead of a TCP one as well.

I believe you need to configure the port in PAC Manager too.

I used to have a strategy I used that would allow you to connect to a TCP port and all the commands sent would be sent out the onboard serial port - used that for debugging serial devices much like you are talking about when using the SCM-232 module. I’ll see if I can dig it up.

1 Like

Here is the strategy. It is set to use serial port 0 at 9600 8n1. You can connect to the IP address of the controller at port 22005 and any key strokes will be passed through to the serial port and responses will be replied. Change the comm handles for different communication settings and/or port.

The archive is in PAC Control Pro 9.4.

SerialProxy.Archive.D01102022.T155955.zip (5.2 KB)

2 Likes

Awesome! Thanks, @philip! You’re always great at answering my questions quickly.

In the meantime, I’ve dug out a SCM-232 module and am jury-rigging the wiring together (connection on the device is RJ-12) :roll_eyes:. I already followed the instructions to configure the built-in serial port on the R1, and the comm handle /should/ be ok (got everything from PAC Manager/Control users guides). So it’s maybe a wiring issue, but we rang out the cables, and they should be correct. This is an annoying one! I figure if I can get it to communicate with the 232 module then I’ll work backwards to see if I can get the built-in port to work. We wanted to keep the module slot open, because we only have 2 spare slots on the RCK-16 right now. I’ll let you guys know what the problem was (if I ever find it…)