USB Mouse and Keyboard Problems GRV-EPIC-PR1


#1

My EPIC PR1 is no longer registering the USB mouse or keyboard plugged into the 2 USB ports. It worked for a while. Now it doesn’t. I have tried various mice and various keyboards which I have confirmed work on other PCs. Very odd.
Anyone else had issues with this?
Cheers


#2

I have not had the issue or heard of it.
What do the logs say?
In groov Manage, under Info and Help - > Logs -> System logs.
Check when you just plug them in and you might see something helpful to yourself or our support team here at Opto.


#3

Hi Ben. Thanks for the reply

Interestingly enough. First thing this morning I powered the unit up and the mouse works first go. The logs show the following when connecting the mouse:

USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-ci_hdrc.1-1.2/input0
When I disconnect the mouse the logs show:
kernel: usb 1-1.2: USB disconnect, device number x (x increments each time I do this. I’ve tried repeatedly harassing it by plugging and unplugging it from both USB 0 and USB 1 but it is working flawlessly now and I as I am typing this I have incremented x to 46.
I then tried a different mouse which resulted in:
USB HID v1.11 Keyboard [Logitech Gaming Mouse G502] on usb-ci_hdrc.1-1.2/input1
x continues to increment
Leaving the mouse plugged into USB 0 I plugged a keyboard into USB 1:
USB HID v1.10 Mouse [Dell Dell Wired Multimedia Keyboard] on usb-ci_hdrc.1-1.1.4/input1

There is another periodic entry that seems to pop up that I don’t really understand:

ntpd[1924]: error resolving pool 0.pool.ntp.org: Name or service not known (-2)
ntpd[1924]: error resolving pool 1.pool.ntp.org: Name or service not known (-2)
ntpd[1924]: error resolving pool 2.pool.ntp.org: Name or service not known (-2)

I will continue to investigate as the day progresses.
Cheers
Sean


#4

Well, thats something. At least you can keep an eye on the logs.
Thanks for checking them…

The error is saying that the EPIC cant get out to the Internet to update its time.
ntp is network time protocol.
0.pool.ntp.org is the time server that the EPIC is trying to resolve the name into an IP address and sync its time.
Either your DNS or gateway settings are preventing that process from happening, hence the name or service is unknown.