Unable to connect to opto 22 eb-1 brains

Using pac manager 10.4
8x opto 22 EB-1 brains

Hello all. I am trying to change the IP address of a few of our opto 22 brains using pac manager. However, even directly plugging in using ethernet I am unable to ‘Find’ them in pac manager. I am unsure of their IPs as they must have changed somehow. Maybe a power outage. I have their MAC addresses but even after hard resetting using a paperclip I am still unable to ‘Find’ them when directly plugged in via ethernet.

I am not incredibly familiar with this hardware any tips would be greatly appreciated. Thank you.

PAC Manager menu under Tools you will see Find Opto 22 MMP devices. Select it and then click find on the dialog that opens. This will scan and locate devices for you and list their IP addresses if they have one. Assuming the computer you are using has its IP address and subnet mask set correctly, you should be able to ping these devices.

Under the tools menu you can also use Assign or Change IP addresses to set them if needed. You may need to do a factory reset otherwise. Before doing a reset, at least power them down and then back up in case they need to get re-established.

Hi Jerry thank you for your reply.
Unfortunately I did try a factory reset and am still unable to locate them using ‘Find.’ I’m now trying the legacy software ioManager and seem to have found one of them. However, the test is failing after inputting the desired ip address, subnet, gateway, etc.

Have you tried the Assign IP Address dialog. If you look at it you will notice that the upper half of this dialog is “Listening for DHCP Discovers and BootP Requests” . Get this dialog open and then power cycle the device. Usually during power up the devices will try to issue a BootP request or DHCP. This dialog will catch them when they happen. You have to see if it shows up in this dialog or not.

(I should mention that firewall on your PC can be an issue as well) If you can isolate your network and turn off your firewall, this may help. Possibly antivirus software?)


This is from pac manager 10.4, not the legacy io manager

EDIT: never mind that error was thrown because i had the legacy software open

So using your advice I was able to finally find one of our devices in PAC Manager. Unfortunately the tests fail. I may be inputting something wrong on my end.

Since you are directly connecting have you set your computer IP address to the same network that you are trying to set the EB1s up on? If not, then the test will fail even if the device has the new address assigned.

Yes we are both on the same network. Would the test be different if i direct connected? I just found this one over the WiFi.

All of our controllers are stand-alone, not multiple controllers on one network. Although we do have one instrument that has two controllers (Opto 22 R2 Brains).
What about the ‘Device Name’ in PAC Manager? On our one instrument that has two controllers, when we connect to the internal network of that instrument, we have to select the ‘Device Name’ for the particular controller we wish to ‘Inspect’ or connect to. Maybe this comes into play when ‘scanning’ the entire network?
Maybe this will help?

Yes there is ‘Device Name’ when I go to inspect.

When we’ve had customers with this issue it is typically solved with one of the following suggestions:

  • You already reset the brain- make sure you are not in bootloader mode.

  • Set a fixed IP address on your PC and disable Firewall (could be blocking BootP) - this was already suggested by others.

  • Suggest using a switch and interface your PC and EB to the switch instead of direct connect.

  • With Direct Connect the PC will configure itself based on initial network interface (standard or crossover configuration)
    When this is the case you need to deactivate and reactive the Ethernet Port since most PC NICs will not reconfigure when you go from standard interface to crossover (direct) interface.

  • In PACManager use Assign IP Address looking for the BootP. Quick Reset (or cycle power) on the EB if you don’t see anything in 60sec but keep the dialog active. Wait another 60 sec after EB boots up.

  • Try a different PC that you have Admin Rights and repeat the steps above.

Don’t think we’ve had a customer not configure the IP address when they go through this sequence.


edit: post above mentioned it