Trouble setting up PR2 IO

Hello first time here,

I recently just got the PR2 in. Downloaded the latest PAC control from the website (10.3). I am trying to configure the IO. I have established communications with the PR2, verified, and downloaded a strategy to the controller.

The problem I am having is adding IO automatically. When I first set up the IO using local(loopback) I get a notification “The Device could not be contacted”. I have also tried the hostname, and IP address. Same result.

If I go ahead and continue to add the devices and points manually, they behave in the program and I am able to control them.

So I was just wondering if there was something silly I missed. It is not a big deal as I know the manually addition works.


Welcome to the Opto forums!
Great to have you here.

Here is how I have my PR1 (PR2 is exactly the same) set up for my local IO.

Sounds like you have the Local Loopback box checked as well.
The only other thing I can think is that when you working with the unit in configure mode, you need to have the PC on the same network as the PR2.
Once you are in debug mode, the local IO is talking to the strategy on the PR2.

Check your PR2 network and firewall settings.
Make sure the PC you are working on is connected to one of the PR2 Ethernet ports that has access to port 2001.