Sliders not responsive


#1

The slider gadgets on my EPIC groov are not very responsive. They were much more responsive on my old AT1.
Screen capture of behavior:
Sliders.zip (463.9 KB)


#2

What version of groov / your EPIC’s firmware is that? I had a fix for that annoying behavior where it bounces between the last scanned value for the tag and the written one in 4.1a; maybe it didn’t work?


#3

ScreenCapture%202


#4

k. Right now things look like this:

  • The code that manages retrieving updates for pages keeps a cache of recently read values.
  • That code issues requests to devices (at whatever scan interval is configured) to get updated values.
  • When those devices respond, that recently read values cache gets updated.
  • Once a second, pages ask for updated values for their tags. Those values are always returned from that value cache.

So the immediately problem is: you issue a write, it gets scheduled in the front of the job queue for the device, but that cache has a stale value in it. So what I do is, as soon as the write has been committed to the device, I update that cache.

That still leaves you at the mercy of slow-ish device responses though. So those gadgets are popping back to the most recently read value from the device until the code is sure the write has gone through, then it should pop up to the written value, without waiting for an additional read response from the device.

So long story short: what do your response times look like at the moment?


#5

It’s not great. I switched off the “write continuously” feature for now. It seems to help. There just is not a change in the setting until the button is released.


#6

Write continuously is extra painful with slow response times, because it’ll try and write many times per second, filling up your request queue. Writes are usually pretty fast, at least; they only ever do one tag/value at a time.