Sending an email from SoftPAC


#1

I have tried to set up a strategy running on SoftPAC to send an email. I triggered it and it gives me error -58. Then I thought… let me check the DNS Server settings and it seems I can’t change it. In PAC Manager it gives me a “Communication error with 192.168.1.70 - 0xE005”. It defaults to 192.168.1.1 (which is my gateway). Next I thought, I still need to load a Root Certificate. When I try to do that in PAC Manager, it says “Attempt to open FTP session failed” Is this possible in SoftPAC?

Any help would be appreciated. Thanks


#2

Can you send email from that PC? (Or access the internet?)
If so, you should be good to go on sending email. The DNS is just that of your PC, which you can get from a command-line prompt by typing:
ipconfig -all


#3

Yes, I can access the internet just fine. I’m typing this on the same PC that is running SoftPAC. I can’t even get an R1 to send an email either. It gives me error -443. I know the script is correct because it is set up exactly like one out in the field and I just tested it and it works just fine. Only difference is that R1 is on a Verizon cellular modem and this R1 is at my house on my home network.

Is it required to have a root certificate loaded to SoftPAC through PAC Manager?


#4

So I really, really need to get this resolved.
I have a strategy running on my PC with SoftPac. I am try to send an email from SoftPAC. I set up the code exactly like the example shows (i have done this before and it has worked just fine). I trigger to send the email and it gives me error -58. There isn’t an error -58 in the list. Can anyone tell me what that error is?
On my network at home I have a Groov AR1 (hardwired to my ASUS router) box and it can send a test email just fine. The PC I am using for SoftPAc is an NUC Intel build. This PC connects to the network by a wireless connection.

Does anyone have any idea? I can give as much info as you would need to help me with this.

Thanks,
Dan


#5

If (Test01 == 1) Then
arrstrServer[0] = "myemailaddress@gmail.com"; // User Account
arrstrServer[1] = “mypassword”; // Password
arrstrServer[2] = “smtp.gmail.com”; // Server
arrstrServer[3] = “465”; // Port#
arrstrServer[4] = “ssl”; // “ssl”, “tls”, “none"
arrstrRecipients[0] = "recipient001@gmail.com”; // Recipient list
arrstrRecipients[1] = “”;
arrstrRecipients[2] = “”; //This blank ends the recipient list
arrstrRecipients[3] = "johndoe@hismail.com"; //This recipient will be ignored
arrstrBody[0] = “Email From a Controller”; // Subject line
arrstrBody[1] = “Hello:”+CRLF+CRLF; // Body starts here
arrstrBody[2] = CRLF; // Could have been combined above
arrstrBody[3] = "This is an example of an email that can be sent from a PAC ";
arrstrBody[4] = "controller. Even though these lines are separate strings, ";
arrstrBody[5] = “they will be concatenated in the body of the email.”+CRLF+CRLF;
arrstrBody[6] = "The pair of CR/LFs above create a blank line for the start ";
arrstrBody[7] = “of a new paragraph.”;
arrstrBody[8] = CRLF+CRLF;
arrstrBody[9] = “Sincerely,”+CRLF;
arrstrBody[10] = “SMTP-Controller”;
arrstrBody[11] = “”; // 1st blank element = body end
arrstrBody[12] = “This is not included in the body.”;
SendMailResult = SendEmail(arrstrServer, arrstrRecipients, arrstrBody);
Test01 = 0;
Endif


#6

Hi Drenton,

I forwarded your info to our support team so they can help troubleshoot.

In the meantime, the help for the SendEmail command shows this for your -58 error:

-58 = No data received. May have timed out if no response in 10 seconds. Check I/O unit power.

Do you have an especially slow connection to the internet, where it might take longer than 10 seconds to get a response from a remote server?

Also, do you have an email server besides gmail you could try? Gmail has made changes to their security requirements which have been messing up a lot of people. Did you check that email account to see if gmail sent you any security warnings? (Sometimes you have to click on something to say: “yes that’s really me,” for example.)

Thanks,
Mary


#7

I have tried everything I can think of. I will try using a different mail server next. Any suggestions on which one is proven?

The only other thing I have noticed is the only R1 controller that works has 9.4c firmware. Three of the R1’s and the SoftPAC is running version 9.5d firmware. I did upgrade SoftPAC to 9.5f and still didn’t work. I am still not convinced that is it though. Can you downgrade the firmware on an R1? If so, where can I D/L version 9.4c.
As stated before, SoftPAC throws up error -58 on my laptop and my home PC using two different networks. My R1 throws up error -443. My Groov AR1 works just fine.


#8

Try Yahoo! or Outlook.

Yes, you can downgrade firmware on the R1.
Find them here; ftp://ftp.opto22.com/Public_Folders_(Unsecured)/Archives_(Software_and_Firmware)/Firmware_Archives/SNAP-PAC_Firmware_Archives/Beta/


#9

After hours and hours on this problem, I finally figured this out. Sending an email with Firmware Versions 9.5a, 9.5d and 9.5e do not work in SoftPAC or on an R1. When I tried loading FW version 9.5f, it killed SoftPAC and it can’t be used any more (seems I’ll have to reinstall it). I tried 9.4c and d and both work, but if you are using gmail you will have to manually load the GlobalSignRootCA-R2.crt to the /pki/root-certs/ path on your R1.

I would like for others to try and use the “newer” FW versions to see if it works for them. I’m totally curious. If they don’t work, then Opto22 owes me a vanilla crunch cone from Dairy Queen (do they still make those?). I truly thought I was losing it.