SendEmail Error Troubleshooting


#1

I was trying to test the SendEmail() function today with our email server, and I’m running into some difficulty.

The SMTP settings and port no. are exactly the same as they are configured in Outlook (which I use daily to send email).

However, when I try to trigger a send email from PAC Control, the error code returned is ‘-11’. The error code look-up translates this to “Could not send data”.

My guess was that I had setup the controller (an S1 with 9.1b firmware) incorrectly. However, it is on the same network/setup in a similar fashion as my laptop which has no problem accessing the email server to download/send my email.

I thought I would test a different email account of mine (a Gmail account) and the only issue I ran into there was a lack of certificate for SSL (which I expected, I didn’t place on in the controller’s file system). I would think that getting denied at that stage meant the send email request was at least sent out.

My question is, what might I check that would be causing what seems to be an issue much earlier in the sending process with our own email server? There isn’t anything distinct about its setup, just the address and port no. 25 and no SSL.

Any suggestions? Thanks!


#2

Tested with Gmail (added the root certificate to the controller) and everything worked as it should have.

Still getting a -11 error code with our email server setup.


#3

I get the -11 error with my email server too (mdaemon).


#4

Hi Guys,

Here’s what my inside sources tell me: -11 means the mail server returned an error (some response that didn’t begin with either a 200- or 300-series response).

How do you guys feel about using a packet sniffer like Wireshark? A Wireshark sniff would allow you to see what the server is complaining about. In particular, you should see UDP packet that echoes the exact response the server returned.

I’ll do more digging on this end & keep you posted.
-OptoMary


#5

I think many (most?) servers expect a server name argument to the EHLO or HELO command, and Opto isn’t sending one. I made this capture from my mail server’s log:

Wed 2011-08-24 08:59:48: Session 6754; child 1; thread 0
Wed 2011-08-24 08:59:48: Accepting SMTP connection from [Somewhere] to [Somewhere]
Wed 2011-08-24 08:59:48: Performing PTR lookup Somewhere.IN-ADDR.ARPA)
Wed 2011-08-24 08:59:48: * Error: * Name server reports domain name unknown
Wed 2011-08-24 08:59:48: * No PTR records found
Wed 2011-08-24 08:59:48: ---- End PTR results
Wed 2011-08-24 08:59:48: --> 220 somewhere.com ESMTP MDaemon 11.0.3; Wed, 24 Aug 2011 08:59:48 -0700
Wed 2011-08-24 08:59:48: <-- EHLO
Wed 2011-08-24 08:59:48: --> 550 Invalid or missing command argument(s)
Wed 2011-08-24 08:59:48: <-- HELO
Wed 2011-08-24 08:59:48: --> 550 Invalid or missing command argument(s)
Wed 2011-08-24 08:59:48: Connection closed
Wed 2011-08-24 08:59:48: SMTP session terminated (Bytes in/out: 12/159)
Wed 2011-08-24 08:59:48: ----------


#6

Thanks for the additional details. I’d recommend that you guys email all the information you have to our support group (support@opto22.com) so we can get their resources working on this too, which will increase the odds of getting a work-around or a firmware update ASAP.
-OptoMary


#7

Has there been a resolution to this problem? We are having a similar problem. We have installed the latest firmware, d, and we continue to get a -43 error, Negative Acknowledgement.


#8

Did you guys configure a gateway and or DNS(if needed)? That might be the cause… Haven’t tried this feature yet though.


#9

The problem I was having was in fact corrected in a firmware update. The -43 error must be related to another problem. From the sounds of the error description, I would suspect the server is returning something like a “Relaying Denied” or other denial message. That could be due to failure to authenticate correctly. Some mail servers need to have a POP mail request made from the device before accepting an SMTP connection, and some of those will not require the POP request if you authenticate. I would suggest you contact support to find out exactly what server response(s) result in a -43. You could also look into installing a packet sniffer so that you can follow the connection process to see what is going wrong. As an alternative, you could try a different mail server. For example, you could create a gmail account specifically for your controller and send through gmail if your local or ISP server won’t cooperate.


#10

I am also getting a -43 using outlook, and gmail works fine. I should note that in gmail, your “sign in and security” should have the “allow less secure apps” turned on. We are using our own server, and so It doesn’t make sense that the domain name isnt recognized… Im having IT sniff it out, but they print up a page of code showing me it works fine on their end.


#11

I’ve seen that -43 occasionally, but then a retry will work. Do you get it every time?


#12

every single time, no exceptions. I truly think the IT department needs to change a setting to allow it.