Hey guys,

So I am planning on using some RIO’s to takeover a few pieces of legacy equipment (very simple logic) and I have it all going in a c++ program. To get it on there I had to upload the file via the groov Manage page, then start/stop via PuTTY (it will eventually be a crontab job).

With the EPIC’s I have had no problem connecting and doing secure file transfers or connecting via Visual Studios to remotely develop/debug. I am assuming these RIO’s might not have the same packages as the EPIC’s…

I just want to make sure I am not missing anything obvious or if it is possible to get similar functionality to the EPIC’s in this regard.


I don’t really follow the question or what error you found.
Let me page @torchard as he has more shell experience than I do.

I cannot get SFTP to work, which works with no issues on an EPIC with a shell license. Visual Studios cannot connect via shell access either, again, no problem for the EPIC’s.

I am assuming it is a difference in the installed packages, but wanted to see if this functionality would be possible to add.

Thanks for the updated error, that is super helpful.

Yes, huh, can confirm.
I have always used scp to move stuff to the RIO and EPIC and your right, the EPIC worked from something like Filezilla, but not the RIO.

Tracked it down to the sftp-server in the RIO config file.
Since it seems you have shell and are comfortable there, here is the fix (well, it worked for me, please report back how you go).

sudo nano /etc/ssh/sshd_config

Once in there, down toward the bottom of the file, make it look like this…

# override default of no subsystems
#Subsystem      sftp    /usr/libexec/sftp-server
Subsystem sftp internal-sftp

Then restart the sshd service with:

sudo /etc/init.d/sshd restart

Confirming that this worked wonderfully. Thanks for the fast response.

This also resolved the issue with my connection in Visual Studios for remote Linux development.



Wanted to add another quality-of-life change you might consider if you’re a developer that wants to upload code and interact via the shell. The default config limits you to one SSH connection, which means you won’t be able to push code if you’re logged into the shell interactively.

In the same file that @Beno mentioned there’s a commented out line in the Authentication session:
#MaxSessions 10
Remove the comment and restart the service as above. Now you can have up to 10 SSH connections.

1 Like