Recover I.P address from SNAP UP1 M64


#1

Hello, i’m Rainer from Valencia, Venezuela.
I have a SNAP UP1 M64 Ultimate I/O and i don’t know the I.P address and i can’t load a program.
How can i recover the I.P address?.
Sorry if my English is not very good. Thanks…


#2

Hello Rainer,

The best way is to run PAC Manager on a computer that is on the same network as the controller.
Once you open PAC Manger, click on ‘Tools’, then ‘Find Opto 22 MMP Devices’.
That will open a new window, click ‘Find’ on the bottom of that window and give it a moment.

Before too long your UP1 should show up and you can see its IP address in the list.

Easy.

Cheers,

Ben.


#3

Thanks for the information Ben, I ran PAC Manager and i did everything you said, the UP1 did not appear…
When i debug the program the next error window shows up: Timeout while connecting to device. Check hardware connection, address, power, and jumpers.
I am using an crossover cable. Can you give me more information about the cable that i have to use for the correct connection?

Thanks Ben. I appreciate your help.


#4

Hi Rainer,

Are you sure your SNAP-UP1-M64 has an IP address already? (If the LED is flashing orange, that means it needs to have its IP address assigned.)

Also, if the IP address was assigned incorrectly, for example, not on the same network as the PC you’re using to communicate with it, that could explain why it does not show up when doing the ‘Find Opto 22 MMP Devices.’ If that’s the case, you might consider wiping out the IP address and re-assigning it with an IP address and subnet mask that work with your PC.

-OptoMary


#5

Hi Mary,

Yes i’m sure that it has an IP address. When it turns on, the LED of RUN is on
How can i do the wiping of the IP address?.

Thanks for the support Mary.


#6

There is a way to interrogate the TCP/IP configuration (IP address, subnetwork address, and default gateway) of the SNAP-UP1 family (SNAP-UP1-ADS, SNAP-UP1-M64, and SNAP-UP1-D64), Ethernet I/O (SNAP-B3000-ENET and SNAP-ENET-D64), Simple I/O (SNAP-ENET-S64), legacy controllers (SNAP-LCE) and the Ethernet add-on card M4SENET-100 for M4 (OptoControl) controllers.

This procedure allows you to interrogate the settings without erasing the device to factory defaults. This is the only method if you do not have a backup strategy for a controller or you do not know the I/O unit configuration, or you have neither knowledge of the strategy or the I/O unit configuration.

The process is described in this document:

You will also need a PC with a hardwired and unused RS232 port.
Install the latest version of PAC Manager.
http://www.opto22.com/site/pr_details.aspx?cid=1&item=PACMANAGER

In a nutshell:

  • Create a cable to connect the PC to the brain or controller’s serial port.
  • With the power-off and the device removed, set the internal jumper to “loader” mode.
  • Open PAC Manager. Select Tools and then “Install Firmware via Serial Connection”. Then select “Install via RS232 Connection.”
  • An application named OptoFlashEnet appears.
  • Set the serial port to the appropriate “COM” value.
  • Select Device and then “Serial Connection.”
  • A dialog appears with the device’s TCP/IP settings.“Read TCP/IP Settings.”
  • Edit the settings and store these changes back to the device. Note, an IP address of “0.0.0.0” means the device does not have an IP address.
  • Power down the device and close OptoFlashEnet and PAC Manager.
  • Set the jumper back to “kernel” mode and reassemble the device.

Bryce


#7

Hi bryce, thanks for the information. I am going to do what you said and then i will write if i make it work.


#8

Hi everybody, the problem have been solved, the jumper wasn’t there so that , i used a cable to reset the controller in order to assign a new IP address and it worked.

I want to say thank you all of you for the support and advices than were realy usefull.

Thanks (Ben, Mary, Bryce and to OPTO22’s family).