Range Indicator Possible Bug

Hello,

When using the Range Indicator gadget (vertically), I want the label to be located at the top of the gadget.

Since the gadget doesn’t offer this, I thought to leave the label as blank and put my own textbox where I wanted the label to be.

For some reason when the label field is left blank, it automatically puts a “:” at the bottom of the indicator.
In the image you can see the colon, when the field is blank.

Also, is it possible to change the color of the triangle indicator to be arbitrary colors?


Yeah, that’s a bug. We had a similar one with slider gadgets that was fixed in 4.3e, but didn’t notice the one here. I’ll add a ticket to fix it.

I think if you put a single space in the Label the : will go away.

I thought of that as well, when I tested it here, I could not get it to work.

With the space there, the label will still take up vertical space it shouldn’t as well. You can briefly see if when you clear the label out in Build mode: the range indicator will extend downward a little further. Moving it causes it to redraw, sticking the colon back in.

It looks like the slider still does this in the latest build.

I’ve also noticed that when changing the “Show Value As” from Value to Percent, it causes the gadget to ignore any custom tic-mark settings and goes to the default. (Not sure if this is intentional)

Although it’s pretty easy to workaround just by leaving it blank and using a value box, or selecting Value and putting % in the Units field.

I would also like to know if it is possible to change the triangle indicator’s color to match my color palette better. It is stuck on blue as far as I can tell.

Looks like the Precision field also does nothing whenever the Show Value As is set to Percent

Is there any update as to when this may be fixed?

That’ll probably be in a 4.4c release, or possibly 4.5a if we don’t do a 4.4c. There’s a 4.4b release due out next week and I wanted to get it in there, but had to bump it for time constraints, sorry.

2 Likes