Previously working email sent , now error -11


#1

Greetings All
I have 4 pac R1 units that are set up to email on alarm conditions via a gmail account. This has been working for me for a few years now. I used the sample code from the opto22 site and tweaked it to suit, worked wonderfully! As of october2015 this has failed to work and I get a -11 error anytime an attempt is made. I have setup a controller outside of our company network at my home to eliminate the possibility of network issues unique to our company network, the same thing happens at both sites.
I have taken the step to weaken security on the gmail account to try and eliminate authentication issues. I am pretty much flummoxed as of now . firmware is r9.1b
Does anybody have any ideas on what could have occurred?
Regards Tony


#2

Hi Tony,

I know we’ve made some updates/improvements in the firmware related to email support. Have you tried some newer firmware?

Our 9.5 feature set (with support for nested subroutines and the RESTful API/webserver) is super awesome!

FYI - when it comes to things like https and email (which also requires security/certificates), the bad guys keep finding ways to hack into everything so updates are inevitable. Darn bad guys.

-OptoMary


#3

Tony, I too have the same problem. I have not upgraded to firmware 9.5 or PAC Project 9.5 yet so I haven’t tested the email function using the new version. However, I did figure out how to send email notifications by using PAC Display Runtime 9.4 to start an email under alarm conditions. But in order for it to work you have to install a dedicated email client software, like Mozilla Thunderbird on the same computer as the Opto 22 software. Also, I had to write code to “clear” the acknowledge feature in PAC Display Runtime that stops the system from sending a second email in a user determined time period. We setup control when the first email alarm notification is sent and when subsequent emails are sent. You also need to tell your OS it is OK for the Opto 22 software to send an email using Thunderbird the first time, but if you check the box to always do this it consistently works for me. Larry


#4

Have you tried testing with an email provider other than Google?

Not sure if it’ll help or be useful in the meantime, but we utilized https://www.smtp2go.com/ as a stopgap when we ran into email issues.


#5

Seems that firmware with updated security certs built in solved all my problems. Thank you for the tip though!


#6

I used new & updated version