PAC Display Runtime running very slowly - displays freezing

Speaking with Opto’s tech support, it seems that there is no problem with either our PAC Display project or PAC Control Strategy with respect to the new versions of the Opto 22 software.

It all runs fast and fine on their test setup and PC.

One possibility is that this is an incompatibility between the Opto 22 PAC Display Runtime software and our particular PC’s display system or driver. Rolling the video driver back to the previous version didn’t help.

But here’s something both amusing and potentially diagnostic:

Because this fancy new system is fast and has a 55" 4K TV as one of it’s two monitors, and I was annoyed with the slow performance I was having with my old desk PC while trying to run Google Earth with a KMZ file with topo maps for the entire earth linked to it, I decided that I should install Google Earth and that KMZ link on this new system.

It’s really great to have a faster PC and a huge display for that! Handy and productive.

But the amusing and interesting part of this boring story is that with Google Earth running on this PC, even if it’s minimized, the Opto PAC Display Runtime now runs correctly. It’s pretty fast, responsive, and the draw windows all update quickly. This makes the new system entirely satisfactory.

So I’ve just been leaving Google Earth running, but minimized, and everything is dandy.

Checking with Task Manager, when I have Earth running, Display Runtime now uses around 4% of the CPU time (as opposed to zero without Earth running). And that makes sense, because it SHOULD be using some clock cycles with all of the polling and updating of various trends, indicators and text from the PAC Controller that it SHOULD be doing.

Meanwhile, the minimized Earth uses around zero.

So something about having Earth running is either stimulating the display driver to “refresh” at a more reasonable rate, or it’s overcoming some power-saving CPU-slowing thing and letting the system rev up and run like it should.

It’s odd, but true.

I see that my posts have had quite a few “reads”, but zero responses. Either I’m boring everyone, or nobody has seen this and doesn’t have any suggestions.

Either way, I thought everyone might at least be amused by this update.

I think your probably have an edge case that no one else on the forums has ran into so there is nothing we can add. Thanks for keeping us updated - it is an interesting finding and hopefully will help narrow down the issue.

Suprise! I just ran into this exact issue with a customer. It is very strange. We can close and relaunch PAC Display and it will either work fine, or stop refreshing after about a minute of running. Seems to be a 50/50 chance on launch. This is on 10.2a. I’ll call PSG and let them know.

I had an issue where the runtime would stop displaying information from the strategy. It never did freeze or anything like that, but all we would see is the # where values should have been.

Our solution was windows update. Not sure if this can help any of you, but I thought I would throw it out there.

I suspect it is some interaction with the PAC Display and hardware/drivers. Unfortunately, this system is on the latest Win10 build 1903 and has all the updates.

The same is true for my system. Latest everything from Microsoft and Opto.

It sounds odd, but for no more trouble than it is, install Google Earth Pro, fire it up, minimize it and see if PAC Display Runtime then works reliably on your various systems.

If it fixes things the same way it does for my system, that’s good evidence… of something. If not, that’s good data for us, too.

By the way: Julio Jimenez was the engineer I was talking with at Opto about this. He would probably like to be in the loop on this.

It really does seem like a display driver interaction issue OR a power saving thing.

I tried updating the display driver on my PC, and Widows says it’s already the latest and best driver. I also did roll the driver back, and while that then prevented the system from seeing the second monitor, it also did not change the unwanted behavior of Opto Display Runtime. So I updated back to the latest again, and that’s when I stumbled upon the Google Earth “fix”.

The PC I see this in is an HP EliteDesk with Intel UHD 630 graphics on the motherboard, no fancy separate graphics card.

Not sure if you are logging any data locally from a trend or event log. If so please add an exception to Windows defender for the FOLDER your files are written too. This issue has caused me many problems:
Unfortunately the KB article ws just recently posted:
https://www.opto22.com/support/resources-tools/knowledgebase/kb87591

Windows Defender tried to scan all the files in any folder that Opto Display uses. This can make the system very slow.

@Sigmo If your are storing data from super trends you really need to try the fix above. I think it will solve the issue. I have had a ticket open on this since December .

@ Norm_Freeman1 I am storing data from a number of supertrends. It can’t possibly hurt to make sure Windows Defender has an exception for the folders where these files are stored. I’ll give it a try. Thanks

There was already an exception for the project folder for Windows Defender Scanning. What did change that we had set before was Windows Data Execution Protection. Typically we put an exception for this for PAC Display to prevent random crashing. It looks like this is in a different location now in newer releases of Win10 (we disabled it, but still had the issue).

There are also some other ‘Exploit Protection Settings’ that can be turned off in that section, so I made an exception for PAC Display runtime and turned off everything that was on by default. I just did that, and the issue hasn’t reproduced itself yet, but we will continue to test over the next few days.

Windows Security
App & Browser Control
Exploit Protection Settings
Program Settings
Add an exception for program name DisplayR.pro.exe
Set overide to off on all settings that are normally on

Yes, working with Julio. This project has a dozen strategies associated with it though, so he can’t really setup a test environment for this project.

I checked the display driver - Just Intel HD Graphics 20.19.15.4835 from 2017 or something like that (HD Graphics 4400), so this hasn’t changed.

By that, do you mean a dozen separate customers’ strategies, or are you referring to the many charts in my particular strategy? I can make a simple system and simple strategy and connect it to the “problem PC” at our location and see if it runs into the same issues, and send that control strategy and the associated display project if that might be of some help.

It would be interesting to see if a much simpler system runs OK on the new PC here, anyhow.

By the way, I have now had one occasion where the PAC Display Runtime came up slowly and would not update its displays at all, again, even though I had Google Earth running in the background. I had to restart the project to get it to run.

But without Google Earth running minimized, I still always observe the effect where the Display Strategy updates very slowly (perhaps once every 8 to 10 seconds) instead of almost every second with Earth running. So that’s remained constant.

I did set up exceptions for the directories where our supertrends are saving their logged data, and that doesn’t seem to have changed anything.

I have not played with the other ‘Exploit Protection Settings’ . I can try that when I am back at work on Wednesday. For now, we’re using the system with no problems (once you get it up and running successfully) with Earth running minimized.

I have not tried using any other programs running in the background to see if they affect the scanning speed the way Earth does for us.

Neither, it is one PAC Display project that is pulling data from several controllers/strategies.

Yeah, it would be interesting if a simpler project did the same thing. I haven’t tested that, but I wouldn’t be surprised if it works okay. I think it is a combination of the size of the project, the particular system and the windows version/settings.

That sounds right to me, too. I did make a much simpler Display project, but running with the same control strategy, and if I recall correctly, it updated faster, but the user interface of PAC Control was still sluggish. I dumped that little project when I reloaded everything on that PC after making some updates, but it would be easy to make something similar.

Also, I have a ton of various SNAP PAC I/O modules, PAC Controllers, etc., around here, so I can easily set up something that would be a LOT easier to set up at your (or Opto’s) end, as well. When I get back in to work, I can set up a system with only a few I/O modules and a smaller strategy just to play with. I have two NICs in this PC, and I can set up this little test system on our main office network. I don’t let the network that our “real” PAC system is on talk directly to the internet, but for the test system, it doesn’t matter, so that will make it really easy to experiment.

Ideally, a small system will show at least some of the symptoms that we’re seeing in the larger one, so it can be reproduced and studied. There are so may uncontrolled variables with an issue like this that it’s almost impossible to isolate the cause on a different setup.

Between Windows, different motherboards and video systems, network differences, and of course, the exact hardware and programs on the PAC end of things, it’s not easy to narrow things down.

If I set up a small system that you can reproduce exactly, and it does show at least some of the symptoms, that will make things more efficient, for sure!

For clarification, you are experiencing sluggish performance and tag update freezing.
I’m experiencing only tag update freezing - performance has been fine. I only get tag update freezing on launch, closing and relaunching eventually works and then everything is normal.

We are both using PAC Display 10.2 (You’re on basic, I’m on pro)
We both have Windows Defender Antivirus exclusions for our supertrend/historical data log folders.
We both are running Win10 Pro build 1903 with all windows updates.
We are both running cpu integrated graphics.
We are both running on solid state storage.

Is this all correct?

That is correct.

I am running an updated version of Display Runtime that Julio pointed me to. It didn’t seem to affect things.

Running Earth Pro at the same time as Display speeds up the operation of Display Runtime. Both the update rate of the tags and the sluggishness of the UI of Display Runtime itself. However, running Earth at the same time does not 100% prevent the occasional freezing of the tag updates on launch. I have to relaunch Display Runtime to try to get it to fire up properly.

Once it launches successfully, then it seems to run fine for days. And it’s acceptably fast as long as I keep Google Earth up and running, even if minimized.

So far, there has been no issues with runtime with the above settings. If we remove the exceptions the issue comes back. Eventually I would like to isolate this down to a specific setting, I’ll test it more the next time I am on site. There are a total of six exceptions setup and I believe this is specific to the latest Win10 build (1903). Another machine with 1809 runs fine, but they are going to update it soon so I’ll see if the issue happens on that machine. It may be a month or so before I can test this out.

I performed the changes to the Exploit protection settings as you’ve described. Indeed, there are six exceptions that I needed to create here as well.

Time will tell if that keeps the program from failing to “update” on launch, because we were not having that problem very often.

However, making those changes did not affect the sluggishness of the UI and the update rate of the tag displays. It still seems to update the various tag displays at about an 8 second interval. However, as usual, if I fire up Google Earth Pro, and let it run minimized, the tag display updates speed up to normal and the UI of the program itself also loses the sluggishness.

Things highlight fast, clicking menu items gets quick response, dragging windows around doesn’t happen in slow jerks (it’s nice and smooth), etc.

So there’s still something going on with this particular PC that seems to be display driver related, and which seems to require the “tickling” provided by having another program up and running.

Odd, indeed! :slight_smile:

The behavior is still the same on this system. It often fails to begin updating on launch, so you just have to close PAC Display Runtime, and then launch it again to get it to begin updating. And you must still have some other program running (even if minimized) for it to ever update on its own.

Once you get it to launch and update, and you have some other program running, it will run fine for days or weeks until the next time you need to launch it, and then you must go through this song and dance again to get it to run.

Had this exact some problem - very slow startup, especially as my supertrends began accumulating data. I was keeping a years worth of data for quite a few supertrends as the customer had requested that. So after a year of accumulation, the startup was taking on the order of 20-30 minutes before the Runtime would begin updating.
After close to a year of battling this, we finally figured out Windows Defender was the culprit. Upon startup Windows wants to scan all the project files that Runtime might be opening - including all supertrend historical data that apparently gets touched by PAC Display Runtime when it first starts. So we made exceptions for not only all Opto 22 program files, but also ALL of the project files as well. Startup is now the snappy result that I expect. I hope this helps.