PAC Display Runtime Initial Screen Opening


#1

I created a chart in a screen. For example, it’s a chart with 30 values… So, 5 rows of 6 colums. Each value has a heading that describes what that value is. Everything is put together nicely and it looks good in PAC Display Configurator. However, when I go to Runtime and I open that screen it looks all jacked up. Lines are missing and colors bleed through the lines. If I click back to the previous screen, then click back to my “new chart” screen everything looks correct. So, it’s like the first initial refresh doesn’t take correctly.

I have noticed this problem in previous projects I’ve done and I just ignored it since I knew that particular screen would eventually get refreshed while an operator was going back and forth to different screens. However, this “new chart” screen needs to be closed whenever the operator moves on to another screen (since I don’t want Runtime to keep updating those 30 values). So, this particular screen will always look unprofessional. I am still using Version R9.3b (I downloaded the newest version, but unfortunately my key to unlock Pro doesn’t work). I tried 2 different computers and all of them had the same effect. So I just can’t see it being a video card problem. Is there a fix for this in the newest version?


#2

Yeah I’ve noticed this too for a while. It’s like the tags have some surrounding screen pixels to box but out that when you initially open the window it sits over any graphic underneath it until you did a redraw of the screen and it looks correct. Almost like its a z order thing. I tried setting the z order of the objects but found it didn’t work. The only way around it is to have the other objects spaced as such that they don’t encroach on this box that is created by the tag. So spacing your tags with enough screen buffer between objects. You can gauge where to put them in configurator because when you select a tag and get the handles for that tag display, that’s the screen portion that will sit above the underlying graphic when the screen first loads. It’s almost like there is no transparency in the surrounding box of the tag (if any of that made sense).
Don’t rule out graphic problems tho. I had a hell time a few years ago where my screens would ‘lock up’ and not refresh the tag data and had to replace the computer with a dedicated graphic card. Then no problems since.

Hope that helps


#3

Thank you for your reply. I completely understand what you are saying. It’s very frustrating to create something and then go back and fix it all. I have tried my Dell LatitudeE6530, a Dell All in One XPS 18 and an Intel NUC Build with a Dell 2314T Screen and all of them show the exact same flaws in the screen. I think I can rule out the problem being a graphics issue.
I do see your point as it does seem to be more profound where you have a tag and the surrounding pixels of that tag. That seems to be consistent with my problem. However, some of the issues there isn’t a tag even close to where is it messed up. Are you running the newest version? If so, still no fix?


#4

Ok, so I found out there was a few tags that were close to my chart that was messing things up. They weren’t that close, but decided to move them anyway and it cleared the right side up.
Also, in my chart, if you click one of the boxed areas (that rectangle toggles a bit), the surrounding area of that is where it gets messed up. So, I changed that box area (again, it’s just a rectangle) in the settings to be displayed as invisible and that works. No more messed up screen… except one or two pixels located elsewhere in the chart. I’ll look into that a little more.


#5

Give us a screenshot to see, thank you!


#6

I thought I had this, but it seems it is directly related to which objects are invisible and their “handles” are outside the foreground color when the screen initially loads. (if that makes sense)… I’ll make some screen shots later today. I really didn’t have a lot of time to spend on this. Wish it would just work.


#7

Have you checked w/our support team on this? (Always best to email: support@opto22.com).


#8

Version 9.5 did not fix this. I am uploading some images to display one of the problems.


#9

So, i just decided to leave enough space around the object to get my box to work correctly. Then I continued on and found out that I had this problem (please see picture attached). Same thing, different area. I am over this issue and i’ll figure out a different way to display my items.