PAC Control deleting code

Using PAC Control Pro 9.6e

I was working in debug and found something I wanted to change. Went to config, changed a variable (in only one chart), downloaded and was retesting. Had some new “weird” issues. Went back to config, changed my variable back, went to download and was met with a compile error in a different chart. I hadn’t worked in this chart at all. Opened the chart, and the block in question, and found all the code except for one line (the beginning of an IF statement) was missing. Opened an archived strategy, from earlier in the morning, and verified this block had all the code. Copied it over and downloaded without issue.

Anyone experience something like this before? I’ve worked with PAC for a number of years now and never seen anything like this. Really scratching my head.

You tickled this bug.

Ah, looks like we have a winner. Sounds like if we switch to 10.5a we don’t have to worry about it anymore?

That’s correct. Yes.
9.6 is a bit long in the tooth. I know there are solid reasons to stay put, there have been a lot of new features and bug fixes added since.

May be anecdotal, but I have found it always safer to do a compile all and then download. The only times I have ever ran into an issue was when I went straight to Debug after changes. Goes for 9.x and 10.x.

My normal download routine is OptoTagPreserve (I setup a batch file for each controller I work on to make this quick) just in case, compile all, then debug.


I’ll keep this in mind (compile first). Thanks for the feedback everyone, it’s much appreciated.

Hi Ben, do you know if there are 10.5a release notes available? I don’t see anything listed on the website yet (unless I’m overlooking).

Yup, there sure is.


Could you go into more detail about this and how you did this. You’re saying if you do a download it backs up your persistence automatically with optotagpreserve? I’ve used it before but did everything manually.

I create a batch file with the OptoTagPreserve command in it. Before download, I run the batch file.

All the batch file has is the command and a pause statement so I can see that it finished okay before closing:

OptoTagPreserve 22001 5000 upload ProjectName

I also have a restore batch file that is setup to allow the backup to be dragged onto it:

@echo off

if "%~1"=="" goto blank

echo Restore file %1
set /p IPAddress=What is the IP address of controller? 

@echo on
OptoTagPreserve %IPAddress% 22001 10000 restore %1
@echo off
goto Done

echo Drag and drop the backup file on the Restore.cmd file!

echo Done!
1 Like