PAC Control cannot communicate with EPIC


I am trying to read some IOs from an EPIC Controller from a SnapPac controller and i am getting a communication error. I’ve done this process before, and have always worked for other devices. For some reason on this one, i can’t make it work.

What Eithernet port are you connected to?
Out of the box EPIC firewall blocks PAC Control on Eth1.
So check if you are using that port and what your firewall settings are.

Currently in Eth 0.

Can you connect to the SNAP controller via PAC Terminal using the same IP and ports as the EPIC using to talk to it?

What is the IP and Subnet of the EPIC Controller ?
I’ve had issues where the subnet would block (your PACs are below .128 while the EPIC is above).

Have you tried rebooting the EPIC Controller (assuming it is first one on the list) ?

HI, Attached my EPIC’s IP Config.

HI Beno,

Ive never really used Pac Terminal, how do i confirm communication between them both through it? What command should it be?


Click on Windows Start, type in PAC Term and select the application:

Once it runs your EPIC and PAC Controller should be in there, if one or both is missing, click add and add the PAC Controller using the IP address you are using.

Once its added, double click on the name to connect and inspect it.

Both are online.

Also, from the EPIC, i can see the IO from the PAC. But when i try to see the IO from the EPIC in Pac, thats when i have the communication issue. So there is communication at least from one side.

This is the error i am getting. But IO is being enabled on the chart, the other ones.

I think I miss read your very first post…

You are trying to see EPIC I/O from a SNAP Pac controller?
ie, use the EPIC as remote I/O to SNAP?

Yes, I need IO’s from different Controllers to communicate because of interlock requirements. So Far, i can communicate from EPIC to PAC, but i cant the Epic IO’s on the Snap Pac.

One of the apps engineers here did a quick test to prove it works (I don’t have a SNAP controller on my desk at the moment) and so we know it should be a quick job.

What version PAC Control are you using and what firmware version are you running on the SNAP and the EPIC?

This is my IO Racks in my EPIC. All are enabled.

These are the IOs on my SNAP PAC. The EPIC one says there is no comm.

Please let us know what version of PAC Control (help about) and what version PAC firmware you are using (PAC Manager).

Pac Control Version

Screenshot 2022-11-02 at 2.18.15 PM

Firmware Version

Nothing obvious is jumping out at me, so I suggest at this point you email our support group and get them to help you through it. They are better setup for that sort of thing than the forums.

There is a typo in the IP address in your strategy:


1 Like

Far out!
Nice eye for detail @philip
Great catch!