OPTOSQL Proxy Error


We did a project where we pushed data onto an SQL Server using SOFTPAC as the control engine and it worked well.

On another project, we used a PAC-R controller as the control engine and we started getting the -415 or some other error when we try to open the SQL proxy communication handle. Using the same control program, we replaced the R2 control engine with the SOFTPAC and the SQL data logging works again.

Any suggestions? We need to use the R2 as the control engine because the sites are remote and the customer does not have a local PC to act as the SOFTPAC Control engine.



I’d guess it’s your network settings (although that “some other” error would be helpful to know too, if you can get it?).
Perhaps your PC running SOFTPAC has a DNS/Gateway that the R2 lacks.

From PAC Manger, go to Tools > Change IP Settings, click “Read Current Settings” then fill in Gateway / DNS Address if they’re 0’s. Usually you’d use the same settings your PC shows when, from a DOS prompt, you “ipconfig” or “ipconfig -all”.

Don’t forget, support is free, best to email them at: support@opto22.com!