OptoControl Factory Floor 4.1

We recently updated to 4.1 in order to prepare to convert to PAC. Out of our 3 IT professionals, 2 are able to open files with the new 4.1 OptoControl. When the 3rd attempts to open the same files, they get the following error:

c:\directory\filename.inf contains an invalid path.

Anyone know of a solution for this? This computer is using Windows 10. We have tried to open as administrator and under compatibility for windows xp.

Thanks for any ideas.

Could be a broken zip file that you are extracting. Try and copy it over to that machine again and unzip it from there.
Also, here are the file types, check them in the directory of the strategy. Not all will be there, but you can narrow down which one is broken on that PC.

Files Related to a Strategy
.cdb OptoControl strategy database
.cdb.txt Text file containing basic strategy information, such as tags and their data types.
.crn Run file (compiled file that is sent to the controller)
.crn1 Intermediate run file (component of the run file)
.crn2 Intermediate run file (component of the run file)
.crn3 Intermediate run file (component of the run file)
.inc Initialization data for variables with “Init on Download” option (component of the run file)
.inf Strategy configuration information
.$cdb Temporary OptoControl strategy database file
.lcdb OptoControl strategy database lock file
.per Persistent variable definitions
..cdf Controller download file for special circumstances
.cht Chart
.ccd Compiled chart code (component of the run file)
.con Online compiled chart code
.wth Watch window file (you name the file)
.otg Exported I/O configuration file (you name the file)
<strategy.date.time>.zip Strategy archive file

We all open the file from the same network drive when we are trying to debug any issues. We also made sure that only one person is accessing the file at the same time, which we still came up with the error.

It is also every one of our projects, not just one.

Had time call Opto and talk to them about the problem. Although I suspected it, it didn’t make much sense given that we just upgraded from 4.0 and everything worked fine before.

The computer we are having trouble with is a Win 10 machine. Per the knowledge base, there is a possible solution for Win 7 computers. I tried it and it worked on my machine.

Anyway, for anyone who comes across this problem and want to know my solution, here it is:


In my case, we still have a computer here that uses Windows 2000 SP 4. That is where I found the dll file to use on the Win 10 machine.