Opto Error -8626


#1

I cannot get the PAC control basic to recognize my Controller, even though PAC Manager can read the controller (via inspect).


#2

jude
check to make sure the default controller port 22001 is allowed through your firewall. also in pac manager just make sure your controller port is set to 22001. pac manager connects via 2001, so in pac manager navigate to communications -> network settings and you can adjust the default control engine port if it has changed. also in pac terminal make sure the control engine port for the controller is set to 22001.
if you want a different port, you will have to change it in both pac manager and pac terminal.

the error refers to incorrect name for the control engine so it might pay to delete the controller and re add it via pac terminal in case something got screwed up somewhere. also it might be a permissions issue when adding the control engine?

hope this helps
nick


#3

Hi Nick, thanks for the response. I didn’t have this problem when I first configured the controller. It came up 2 days after and the worked fine when I started it again. Sometimes the PAC control doesn’t read the controller and when it does, it inputs the controller name twice on the “configure control engine” tab (i.e. \SNAP PAC\SNAP PAC, RATHER
I’ve tried what you suggested by changing the pac manager’s control port to 22001 via Communications>Network Security, but it’s still the same problem.


#4

*rather than just SNAP PAC


#5


#6

Here’s a picture of what it does now


#7

Quick questions,that could just be relevant?
Q1) What Windows operating system are you using to run PACProject?
Q2) What version of PACProject are you using?

As a long shot I’m thinking controller timeouts and retrys due to poor network connections, cabling etc, but duplicated controllers names smells a bit like soemthing I have seen runnign PACProject using Windows8, due to the way that Windows tries to handle local and remote registry keys for cloud support, something that Opto22 have had to resolve by moving the hardware registry keys in 9.4 from where Microsoft thinks they should be.


#8

Hi gmitchell

Q1) I’m using Windows 8.1 Enterprise
Q2) PAC Project R9.3004


#9

Welcome to the OptoForums, Jude!
As gmitchell mentioned, 9.4 is what you need, it solves exactly what you described above.
-OptoMary


#10

Hi All,

Thanks for the support. I called opto support, and was directed to this article (which I’ll try today)

http://www.opto22.com/site/knowledgebase/kb_view_article.aspx?aid=2298

KB83358

Loss of communication from PAC Project software on Windows 8 computer to SNAP PAC controllers

Revision: 1.0

Published: 3/10/2014

Applies To

PACPROJECTBAS

PACPROJECTPRO

Versions

Problem was discovered in version:

R9.3x

SYMPTOMS

Loss of communication from PAC Project software on Windows 8 computer to SNAP PAC controllers. Viewed in any PAC Project configuration window, a configured controller that appears normally as, for example, PacController is displayed as \PacController\PacController after the problem occurs.

When you try to modify a controller, the network is locked into 255.255.255.255 and cannot be altered. An attempt to add a new controller results in the same corrupted name and network. No communication from an affected PC to a controller (including a SoftPAC local controller) will occur while this problem is experienced.

WORKAROUND

There are three possible workarounds.

Workaround #1:
1.Try running the Windows 8 compatibility troubleshooter on the PAC Project executable files Term.exe, Control.basic.exe and Control.pro.exe. Or manually configure these files to run in “Windows XP Spk3” compatibility mode.
2.After running the Compatibility troubleshooter or manually changing the compatibility mode to Windows XP Spk 3, manually recreate the controller definitions using either PAC Term or PAC Control.

Workaround #2: Disconnect your Windows 8 Microsoft cloud-based account and switch the machine to use a PC local account (Desktop Configuration Tool Icon > Change PC Configuration > Users > Your account).

Workaround #3:
1.Exit PAC Control.
2.Right-click the icon for PAC Control and choose the “run as admin” option.
3.Add the control engine again.

RESOLUTION

Opto 22 is investigating this issue.


#11

Yes, that’s been fixed in 9.4, and we updated the article to include that. I’ve used Workaround #3 multiple times, if you would rather stay at 9.3 for now.