NTP time zone and Ignition Edge

I’m having some issues in setting up my groov Epic to use an NTP server. When I set up the NTP server in groovManage, it only shows my correct local time if I set the time zone to Universal or GMT. We are in the Eastern time zone. If I set the time zone to Eastern, the hours end adjusting off of our correct local time. In addition, no matter what setting I use for the time zone, Ignition Edge shows the correct local time, but lists it as GMT+0:00. We have our Ignition Edge configured to sync the historical data to a “full” Ignition server. When the data posts, it posts 5 hours in the past since the server is acknowledging the time and offset from the Edge server. I believe there are two issues. First, there seems to be an issue with setting the time zone on the EPIC. Second, there seems to be an issue with passing the time zone information to Ignition Edge. I’m not sure if I should post the second issue to the Inductive forums or not, but I figured I’d post about both here first.

Hardware: GRV-EPIC-PR1, sn 754583
System Version: 1.3.2-b158
groov Manage Version: 1.3.2, source f1b9e73c15c3

Maybe there is a bug, but are you sure your NTP server is correct?

I’m pretty sure that all Ignition historian data is sent and stored UTC+0. It sounds like your NTP server is giving you UTC-0500 as UTC+0,

0.pool.ntp.org does the same as our local NTP server.

I did a search of our internal ticket system and can not find anything regarding setting the time zone.
What I did find was a ticket regarding groov View. If you change the time zone in groov Manage, it does not pick up the change straight away in groov View. You need to reboot the controller. We have found the problem and it will address it in a future firmware release.
That said, I wonder if you are seeing the same issue with Ignition… I am busy with our class at the moment, but will try reproducing it here.
If you get a moment, try restarting Ignition Edge from groov Manage after you change the timezone and see if it picks it up.
Regarding not setting the time correctly from the get go… Have you reviewed this video on how to do it? (Hint. The order you do the settings matters)




Are you seeing the wrong time on the Ignition Edge status page?

Or just in the historic data?

Update: While our NTP server is reachable, I’m working with our IT on determining why it’s not pushing the time through our internal firewalls to the dev netowrk.

I’ve currently set the time manually to “New York” aka ET. The groov Epic is showing the correct local time.


When looking at the Edge status page, it shows GMT.


When I rebooted the devices again this morning, Ignition Edge now shows the correct time zone. I’m still working on the issues reaching the NTP server(s), but at least now Edge seems to be reporting it correctly.

We ran a test here and found the same.
You set the time (zone) in the EPIC and the Ignition Edge only picks it up when it starts or restarts.
You don’t have to reboot the whole box, just restart the Edge Gateway.