Node Red Error connect to Epic

HI Guys,

Got this error setting up a new Epic with Node Red.

“Address not found. Error code: ENOTFOUND from system call “getaddrinfo””

Any suggestions on a quick fix?


Which node package are you using?

Version 2.2.2

I also cat get the email node to download as well. Maybe it needs another version of it?

I should have been more clear, which node is throwing the error? There are three Opto node packages for IO, PAC, and groov View.

The email download could be unrelated, are you able to download any other node packages or are they all failing?

Sorry, PAC read node would be one. I have used that one previously in other flows, without no problem.

Are you just communicating with the local strategy via localhost?

And when using the PAC read node in other flows, is that on the same device or different EPICs?

IM using the node within the same Epic, local host. When using on other flows, its a different EPIC. I mentioned it to confirm that I’ve used this same one in another.

Networking settings.
Either your gateway cant route to the IP you have, or the DNS cant resolve the host-name you are using.
Same two options is causing the email node error as well.

1 Like

Hi Beno,

Just re-did the setup, and now there is no error. But cant seem to get something from it.

What is your PAC node configuration? I see you put the date in msg.payload, are you putting the PAC read result on another property? Your debug will only show the payload, not the PAC value.

Edit the debug node to output the complete msg object.

Exactly, im not getting a value from the node. Here is my setup.

Your debug is only showing msg.payload, the PAC value is being written to a different property. Edit the debug node to output the complete msg object.

thanks, i got a reading now. Thats odd, i had never had to do that before.