Node-Red Dashboard won't install

I had to reset my RIO - power monitor and now the dashboard is missing and it will not install from the node-red store. Has anyone else had this problem? Any fix/work-around?

Thanks in advance!

What are you seeing when you attempt to add the package through the manage palette window?

Do the RIO and the PC you’re on both have a gateway to the internet?

2023-05-08T22:31:20.346Z Install : node-red-dashboard 3.4.0

2023-05-08T22:31:20.999Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-dashboard@3.4.0
2023-05-08T22:32:18.240Z [err] npm
2023-05-08T22:32:18.247Z [err]  
2023-05-08T22:32:18.250Z [err] ERR! Unexpected end of JSON input while parsing near '...0","gulp-replace":"^1'
2023-05-08T22:32:18.347Z [err] 
2023-05-08T22:32:18.351Z [err] npm
2023-05-08T22:32:18.352Z [err]  
2023-05-08T22:32:18.353Z [err] ERR!
2023-05-08T22:32:18.355Z [err]  A complete log of this run can be found in:
2023-05-08T22:32:18.404Z [err] npm ERR!     /home/dev/.npm/_logs/2023-05-08T22_32_18_268Z-debug.log
2023-05-08T22:32:18.488Z rc=1

I’ve never seen that error before — which firmware version is the RIO at?

Also, by any chance does it have a shell license…? There might be more info in the full log file.

RIO power monitor
F/W 3.4.1-b.62
Node-RED version 2.2.2
Node.js version v12.22.1

No additional licenses.

ok, I’m on the same firmware but don’t get the same error as you.
Can you double check your network configuration? Both the RIO and the system you’re viewing the editor on both need access to the internet — are there any network-level firewalls or additional security set up?

One other thing to test would be to try to install another node package, if that works it’s a problem with the dashboard, but if it doesn’t, it’s more likely the network.

It did take 2 minutes for the installation to complete, but these are my logs:

2023-05-08T23:00:05.521Z Install : node-red-dashboard 3.4.0

2023-05-08T23:00:05.691Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-dashboard@3.4.0
2023-05-08T23:02:07.300Z [out] + node-red-dashboard@3.4.0
2023-05-08T23:02:07.300Z [out] added 51 packages from 99 contributors in 108.066s
2023-05-08T23:02:07.640Z rc=0

I can ping google from the RIO.

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=54 time=12.5 ms
64 bytes from icmp_seq=2 ttl=54 time=11.6 ms
64 bytes from icmp_seq=3 ttl=54 time=12.3 ms

--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 4ms
rtt min/avg/max/mdev = 11.636/12.162/12.536/0.403 ms

I can’t install anything. I wonder if it’s being blocked by a firewall… our IT consultant… :expressionless:

So, I took it home where I have complete control of the network/interwebs. I can rule out firewalls etc. Both my laptop and the RIO have access to the internet and the same error pops up. This happens for any node I try to install.

Do you have a backup of the configuration before you did the factory reset? If so, you can try to restore the Node-RED backup via the Maintenance tool in groov Manage. This should also install the custom nodes you are using in you Node-RED flows. No Internet connection needed for this.

1 Like

I finally got it installed. I had to factory reset and not recover any data/programming. Before I put my project back onto the RIO, I installed the dashboard and groov nodes. I then recovered my project and other data/settings.

1 Like