Node-RED Contribs Won't Install


#1

Anyone know why I can’t install any new Node-RED contribs to my Groov box? It is behind a new router but I’ve never had to do any sort of port forwarding before just to install a new module. Had this problem before when I didn’t put in the DNS server in the Groov but that’s not the case now. I can resolve the host name in the log just fine from my PC and we’re on the same subnet.

Thanks,

Dave

Here is the log:

Welcome to Node-RED

===================

3 Jan 00:32:33 - [info] Node-RED version: v0.17.4

3 Jan 00:32:33 - [info] Node.js version: v6.3.1

3 Jan 00:32:33 - [info] Linux 3.0.35-groov3.5 arm LE

3 Jan 00:32:35 - [info] Loading palette nodes

3 Jan 00:32:45 - [warn] ------------------------------------------------------

3 Jan 00:32:45 - [warn] [rpi-gpio] Info : Ignoring Raspberry Pi specific node

3 Jan 00:32:45 - [warn] ------------------------------------------------------

3 Jan 00:32:45 - [info] Settings file : /var/lib/node-red/settings.js

3 Jan 00:32:45 - [info] User directory : /home/dev/.node-red

3 Jan 00:32:45 - [info] Flows file : /home/dev/.node-red/flows.json

3 Jan 00:32:45 - [info] Server now running at https://127.0.0.1:1880/

3 Jan 00:32:46 - [info] Waiting for missing types to be registered:

3 Jan 00:32:46 - [info] - modbus-client

3 Jan 00:32:46 - [info] - groov-project

3 Jan 00:32:46 - [info] - groov-data-store

3 Jan 00:32:46 - [info] - modbus-read

3 Jan 00:32:46 - [info] - groov-read-ds

3 Jan 00:32:46 - [info] - groov-write-ds

3 Jan 00:34:15 - [info] Installing module: node-red-contrib-modbus, version: 3.0.0

3 Jan 00:35:31 - [warn] Installation of module node-red-contrib-modbus failed:

3 Jan 00:35:31 - [warn] ------------------------------------------

3 Jan 00:35:31 - [warn] Error: Command failed: npm install --save --save-prefix="~" --production node-red-contrib-modbus@3.0.0

npm ERR! Linux 3.0.35-groov3.5

npm ERR! argv “/usr/local/bin/node” “/usr/local/bin/npm” “install” “–save” “–save-prefix=”~"" “–production” “node-red-contrib-modbus@3.0.0”

npm ERR! node v6.3.1

npm ERR! npm v3.10.3

npm ERR! code EAI_AGAIN

npm ERR! errno EAI_AGAIN

npm ERR! syscall getaddrinfo

npm ERR! getaddrinfo EAI_AGAIN registry.npmjs.org:443

npm ERR!

npm ERR! If you need help, you may report this error at:

npm ERR! https://github.com/npm/npm/issues

npm ERR! Please include the following file with any support request:

npm ERR! /home/dev/.node-red/npm-debug.log

3 Jan 00:35:31 - [warn] ------------------------------------------


#2

Dave, we see this error when the groov Box network settings are not quite right.
Checking it on the PC while on the same subnet is not really going to show the problem (as you have discovered). The PC settings are not related to the groov Box IP settings at all.

0. First, are you plugged into Eth0 (on the left) or Eth1 (on the right) of the groov Box?
Next, go to groov Admin and look at the network settings.

Things to check;
1. If you have a DHCP or Static IP address configuration. Either way, make sure the Netmask and IP address are what you expect.
2. (Hostname sorta does not matter in your error). Make you seeing the right DNS address. If its Automatic, you may not know what you are getting from the router. It might be worth forcing an address as I have here.
3. This is critical and goes back to the first question. If you are not using Eth0, you need to make sure the drop down reflects your gateway port. If the gateway is not set for the correct interface, then your DNS (where you are getting the error) will not matter, even if it is correct, the gateway address will not find the DNS server you have specified.

I think you will find some combination of the above is stopping your DNS server from resolving that address and thus the package is not installing (but you are able to use groov just fine).


#3

I checked all that before I posted. The issue seemed to be the router I was using. We use Cradlepoint cellular modems in the field and when I put the Groov behind it in my lab it wouldn’t install. Put the Groov behind my office router and it worked fine. 'Tis a mystery because I’ve installed the modules in Groov boxes in the field before.

Anyway, thanks for all your help. You guys are the best.

Dave


#4

Dave, Had a feeling you had… but in the interests in those following along and searching the forums, I sometimes double up info.

We also use Cradelpoints here for our trade show demos. Generally don’t have a problem with them.
I suspect that there is something going on with the gateway or DNS settings just the same, its not the way Cradelpoint hands out the settings to a PC (other wise your PC behind it would have had issues), but the way its handing them out to the groov Box.
Be good to get to the bottom of it, otherwise every Node-RED flow that uses domain names over static IP addresses is going to have problems.


#5

Sorry. Sometimes I forget it’s a forum not email. :slight_smile: Let me spend some time with it when I get a moment and I’ll post my results. This is a different model (IBR 650) than ones we’ve used in the past so maybe it’s something I’m not aware of. I need to know myself because we need to be able to do updates when these things are installed.

I’ll keep you posted.

Thanks,

Dave


#6

I had to set my Groov back to factory defaults and this problem surfaced again. This time I’m not behind a Cradlepoint but a LAN router.

Any thoughts???


#7

RTFP;

“3. This is critical and goes back to the first question. If you are not using Eth0, you need to make sure the drop down reflects your gateway port. If the gateway is not set for the correct interface, then your DNS (where you are getting the error) will not matter, even if it is correct, the gateway address will not find the DNS server you have specified.”

I am using eth0 but because I’m such a smart IT guy I didn’t bother to read this carefully.

Those whom the gods wish to destroy… and all that stuff. :confounded:


#8

Thanks for being honest…
We can all miss stuff… Including calling DNS DHS twice in the step three… [gulp].


#9

I saw that, but I thought it was some kind of Aussie acronym I hadn’t heard of. :wink:


#10

If it isn’t, it should be… Just went back and fixed it… Thanks for putting up with me.