MQTT Broker not connecting in Node Red

Hi Guys

I recently had to upgrade my EPIC due to a massive failure, but finally got all up and running. I am trying to get all my features back to normal. One of them was running MQTT Broker within Node Red. I am using the same setup as previous, but i cant seem to get a connection. Ill attach my setup on the Topic.

Screenshot 2023-07-26 at 1.15.39 PM

Seems like either a network or credentials issue.
The broker will ‘connect’ regardless of the topic, so that can be moved aside for now.

Check for a valid gateway and DNS. Your Node-RED will need to be able to get onto the internet to connect to that broker (I cant read the main part of the URL, so cant reference it by name).
The EPIC will also need to be able to resolve that broker host name, so you need to be sure your network settings allow that as well.

Tip: Use the network tools ping and NsLookup. Try and ping that broker URL from the EPIC tools and try and do a name server lookup from groov Manage tools to ensure right from the EPIC to the broker you have connectivity.

If both those check out, then double check your broker user/pass and see about its SSL certificate.

Hi Beno,

I tried the NSLookup and it seems to connect.

How i set it up on the connections is by using this,


Thats how it always worked for me.

Do you need the “Use TLS” box checked if you are using encrypted port?

You posted a screenshot of the mqtt-broker node with the port field not set. The Server field is too long to see from the screenshot. In your previous post you said,

How i set it up on the connections is by using this,


That string includes port :8883 as part of the string. If that is the same string you use in the Sever field of the node, I would guess removing :8883 from the Sever field of the broker node and adding 8883 to the port field of the broker node might enable the node to make a connection.

1 Like

HI All

Been doing some troubleshooting on a Home Groov Rio that i have and I was able to get the MQTT Broker listed before working, and also a AWS MQTT broker as well.

On the second image, the host name is written this way,


I did these exact setup on the Main PLC (The one with the problem) and i cant seem to get them running. There are two differences on these to Devices, 1 - Different Network, NodeRed Version Difference.

On the device with the communication problem was recently updated to a new Firmware and NodeRed version (But not the one released yesterday).

They use to work before i did the Firmware Upgrade some time ago. Adding to this, i have another PLC that i cant seem to the get either running.

Ill keep checking my network setup to see if its that. But if you guys think of anything, let me know.


You are not putting the URL or port number in correctly as pointed out by @Indigo


On the image that you screenshot, the broker is actually working on it. With that same setup. I also tried as Indigo mentioned, with out luck.

Both instances, it stays in connecting status. I opened up an inquiry for the VPN device to see if that has to do with it. The Groov Rio that has the broker installed has no problem at all with it, but its in my network.

Look at the Node-RED log from the groov Manage Node-RED menu.
See what it tells you.
Bottom line. Its looking more like a network issue, not a Node-RED issue.

This is the log from the Node Red. At least the AWS one connects, all though drops a few seconds later.

Ill stll working the IT portion just in case something is blocking it.

@hcopsc1 looks like you’re using a free Hive MQ cluster. Did you go to “Asset Management” in the top of the Hive MQ cluster details page and create credentials for your broker? You need to create credentials for Publish and Subscribe, and then enter that same user/pass into the Security tab of your MQTT node.

HI Guys

Thanks for the help. Had to reboot my network and update my Hive password.

I confirmed the network functionality once i was able to ping it.

then, i confirmed i had the proper credentials. Now we are connected. thanks guys.