Missing PAC Display Window?


#1

Hi Everyone,

I’m in my infancy of becoming familiar with PAC Project but I’m making headway…or was.

Today I was working with my main window in PAC Display Configurator (displays various gauges with inputs supplied by -20/+20 analog input modules) trying to manipulate it’s screen position when opening PAC Display Runtime and I had changed the dialog box position option (at the time not realizing it would only apply to dialog boxes, not my window, haha) and clicked save and ran PAC Display Runtime.

Upon the program opening, my main gauge display window was missing and there was an error message of some kind (I figured it was just something to do with a setting I changed so I didn’t take note, acknowledge it, and moved on). Only a sub-window was available and the button that takes me to my main window would only re-route me to an empty PAC Display Runtime Window.

Further investigation in Configurator revealed that the main window is just non-existent anymore. I’ve got a “relatively” recent back-up but still a bit of work will be required to bring it back up to speed, so not the ideal situation. Can anyone offer some insight or help?

Thank you and I look forward to being a part of the community here!
-Tom


#2

What version of PAC Display?
Was this project upgraded from an earlier version?

I’ve had an issue where a large PAC Display project gave me issues with one window (which eventually disappeared like yours). Turned out that somehow this one window didn’t get “upgraded” to the current version of PAC Display and was causing issues (according to Opto22 support). Kind of a strange one, and not sure how that happened. Fortunately I was able to export the window from a backup and then import it into the project and didn’t lose too much.

I would try deleting the {project name}.ini file and see if the window will open after that (make sure you have a backup of your project).

Another thing you could try is to make a copy of your backup project and then see if you can figure out which of the W00xx files is the window that is missing in your broken project - then copy that file from your broken project to the backup projects folder (writing over the one that is in there), open it and see if the window opens. Then export that window and import into your broken project. Not sure if that will work, but otherwise you may need to reach out to support.

In the future, make use of the File | Archive Project during development so you have backup copies - unfortunately PAC Display can’t be set to do this automatically like PAC Control does.


#3

It’s 9.6g.
Wasn’t upgraded from earlier version.

I tried deleting the .ini file per your instruction with no luck.

I also tried messing with the .W00xx files like you said and that was a good idea but didn’t work. It did help me identify that the .W0001 is my main window that’s missing. It still exists in the folder but it still doesn’t display as it’s supposed to.

I definitely plan on more regular back-ups. This was a very immature iteration of my display so I wasn’t too worried. I never thought the window would just disappear without a major screw-up on my part, haha.