Lost settings on Groov EPIC while updating firmware on 2nd unit

This may have been a fluke or a coincidence or something else, but here is what happened this morning…

We have been running our Groov EPIC fine for about 10 days, 24 hrs/day. I saw a new firmware was available, but since it was not a good time to stop the program, I decided to wait.

Meanwhile, we ordered and received a second identical Groov EPIC. I unboxed it this morning, hooked it up, set up an admin account (used the same user name and password as the original unit), uploaded the license, then went and grabbed the latest .bin firmware file and then proceeded to update the firmware.


I know it got past the first few green checkboxes on this screen, but sometime after that, the other EPIC unit that has been running for 10 days suddenly rebooted and then when it came back on, it was as if it was a brand new unit, asking to follow the set up procedure. So I have proceeded to set up that unit with admin name & pwd, license, firmware, etc.

Did my update of the firmware on the second (new) EPIC somehow affect the one that was running? I did pay close attention to the IP addresses and am sure I was updating the new unit. The only thing I can think I did wrong was creating the admin account name & pwd to be identical on both units.

Did the firmware on the old unit actually get updated?

No, after the first (running) unit rebooted, it was still running the original firmware. Since I was starting fresh, after I reinstalled the license and such, I updated the firmware to 1.4.2-b110 and it stuck. Am now updating the second (new) unit, which never did take the firmware. I am really perplexed if this was a coincidence, because the first unit ran perfectly for 10 days and then suddenly it’s wiped clean.

I can only add that I have had, at different times, 5 EPIC PR1s on my desk all in various states of firmware updates, all with the same user/pass and and I have never seen anything like you described.
(We shipped 70 demo centers and I had to set each of them up and update them before they went out - hence seeing and doing this a LOT of times).

So after doing the whole setup again from scratch, I eventually started up my PAC control program and all worked EXCEPT the part that takes the RS232 data from the a digital scale, which makes sure there are 16 characters and then parses it up according to the instructions I did. Instead of 16 characters being transmitted, it is totally different:

Original data received via RS232 looked like this:
.+ 0117 0000 (which, when parsed according to my code, it became 11.7 lbs)

Now the data received via RS232 looks like this:

I checked and re-checked all of the communication parameters in the scale (9600 baud, no parity, etc), and they are all still the same as they were and match my comm handle (shown below)

I swapped out the Groov module GRV-CSERI-4 with an identical brand new unit (just in case the original one might have gotten damaged), and even swapped over to a different scale (same model, etc.) but in both cases, the RS232 data comes out looking nothing like it did before. I guess the only thing left to change out is the 3 wires connecting the scale and the Groove module?

Posting this here just in case anyone can offer a clue as to how this happened.

What version PAC Control and what version firmware on the EPIC?
There was this exact bug in an older version of PAC Control.
You might need to contact our support folks to get sorted.

PAC Control Basic v. R10.2b, build date June 3, 2019

Firmware on EPIC is 1.4.2-b110.

I hope the solution is as simple as updating PAC Control Basic. On a separate PC, I have v. R10.2a (build date Nov. 27, 2018), so I can use that PC if it will help.

Please advise who ‘the support folks’ are that I should call or email.

Found the KB on it.

You are using 7 data bits, so have hit the bug.

Support at opto 22 dot com.

BAM! That did the trick! Thank you for pointing this out. Never would have found it.

Just to close the loop on this, I went back through my browser history just before our EPIC rebooted and was then wiped clean, and I believe that (contrary to my own recollection) I had erroneously tried to update the firmware on the EPIC that was running in our plant. The last browser link I had open was, which corresponds to the unit that was running in the plant. I must have clicked update and from there it was all downhill. Lesson learned!

Phew. Thanks for letting us know.