IO unit communication fail in GRV-EPIC PR2 controller

Hi all,
I am using Groove epic PR2 controller for data communication with Modbus TCP IP device.
For this purpose I have tried using MMP. But communication with IO unit is not able to enabled. I tried manually by selecting yes in IO unit page online. But it will automatically goes to NO option.
After lot of trials I have shifted to MB Slave chart. But flow is stopped running at waiting for incoming connection command.

As you have found, you cannot connect to a Modbus device using the IO unit section in PAC Control. That section is only for OptoMMP devices.

You have found the Modbus Integration Kit, which would allow you to communicate with a Modbus TCP device. However, you do not want to use the “slave” chart for this. That chart is so a Modbus “master” can read values from your strategy - which is rarely needed.

You want to use the subroutines that are included with that kit to read the values from your Modbus device. The PR2 is the “master” or “client” and the device you are reading and writing data from is the “slave” or “server”. The various subroutines are used to read and write data to modbus slaves/servers.

Dear Philip,
Thank you for your quick response. And the problem here is groov epic PR2 is showing I/o unit communication error.i have used enable communication with I/o unit command in my pac program but no use.
2nd problem is I have a device that supports Modbus TCP client protocol. So I want to make groov epic PR2 as Modbus TCP server using either memory mapping with unit ID 111 or a special chart provided in Modbus integration kit. But both ways are not working here.
I am using pac project 10.4 version

Where is the IO unit you are trying to talk to? Is it on the same network? If it is the local IO on the PR2, do you have the Local (loopback) checked?

Okay, then either of those methods will work, but note that the TCP port that the PR2 listens on for Modbus access to the memory map is port 8502, rather than the default 502. For the slave chart, you will need to choose a port that is above 1023.

Dear Philip,

Here I am attaching the screenshot of the error.

I have set primary address as loopback.

Can you please take a screenshot of the IO_Unit configuration screen and post it here.


Ok here it is…

Does it work if you remove the secondary address?

No. At First I haven’t added secondary address. After found the error, I have added secondary address. But still no use.

What network address is your EPIC on?
(Screenshot of the network status might help).
What is the control engine configuration in the PAC Control strategy?
(ie, is the strategy running on the EPIC or some other control engine?)

The reason I ask is because the EPIC and rack of IO are on the same rack. There is (should be) no actual network traffic getting from the PAC Control engine to the IO. (Hence local host).
We have thousands upon thousands of people running EPIC with IO modules and this is the first time I have heard of an issue of a controller talking to its own rack of IO.
There is some configuration that we are missing here.

Yes. I have been using Opto controllers since last 9 years. And this is the first time I am getting error for IO unit.
My PC IP address is, Controller IP address(Primary) is I am using 4 Channel Rack for mounting GRV-PSAC, GRV-EPIC-PR2, and GRV-CSERI-4. No other module in the network is using the same address.

I think at this point you should shoot an email to our support team and get them to take a look at your config.