Installation for Groov Nodes Fails - SOLVED

I’m trying to add the Groov nodes to my Node-RED installation and it fails. I have the most current version of everything installed.

Here is what the log says (see below). I hope it means something to someone. It surely doesn’t to me. Thanks.

Edit: So I looked at the troubleshooting guide and it said to make sure the Groov could access the Internet. I knew it could because that’s how I accessed it, but only by an IP address. Turns out I didn’t have the DNS settings configured so it couldn’t resolve any host names.

Error: Command failed: npm install --save --save-prefix="~" --production node-red-contrib-groov@1.0.2
npm ERR! Linux 3.0.35-groov3.5
npm ERR! argv “/usr/local/bin/node” “/usr/local/bin/npm” “install” “–save” “–save-prefix=”~"" “–production” "node-red-contrib-groov@1.0.2"
npm ERR! node v6.3.1
npm ERR! npm v3.10.3
npm ERR! code EAI_AGAIN
npm ERR! errno EAI_AGAIN
npm ERR! syscall getaddrinfo

npm ERR! getaddrinfo EAI_AGAIN registry.npmjs.org:443
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR! https://github.com/npm/npm/issues

npm ERR! Please include the following file with any support request:
npm ERR! /home/dev/.node-red/npm-debug.log

1 Like

Nicely self-solved.
We have seen this one a few times, the key in the error log is the ‘syscall getaddrinfo’, it throws an error trying to resolve the the address of the npm install.
Just as you found, its a DNS issue.

Thanks for updating your post.

Hi Nathan, welcome to the forums.

It all boils down to what sort of network are you on?
If you are on a network with a DHCP and DNS server, you don’t have to do anything, those options will be filled in by those servers and you are done. Just leave them blank and go to work.

Since you say you are having similar issues as the author of this thread, it sounds like you are on a non-standard network.
Do you have a computer on the same network?
If so, you can open a cmd window and issue the command ipconfig and then take the results of that and enter them into your RIO.

Let us know how you get on.

Hello, I actually just deleted my post due to how easy the solution was, but apparently you were quicker than that, impressive! I’m used to setting up static IP’s being from the industrial world but I don’t know how to setup custom DNS information. So, I instead connected to my work network and changed the network connection to automatic in the RIO, let the DNS address get pulled from this, and then it worked.

2 Likes