Igniton designer can't launch please help

Anyone can help me to fix the igniton designer it can’t launch after login

Just double checking that you remembered to turn it on in the EPIC?
Are there any errors? Can you download the jnlp file? Does it launch but not connect?

yes, i download the designer jnlp file, and after that it can launch until the login page but after i key-in username and password it will automaticlly closed

That is odd.
Try stopping and starting the gateway.

How? can show the procedure

Its very easy, just go to you your Ignition screen in groov Manage and turn off Edge and designer, click save.
Wait about 5 minutes, then turn both of the the switches back on and click save. Wait 5ish minutes and see if you can log in to your designer.

Greetings @Beno,
I am Steven, working with @ngzhenghui.nzh. We have tried your solution but it didn’t help with our problem. Here I explain more detailed about the problem:

  1. We already enable both Ignition Edge and Designer in groov Manage.
  2. We can launch Ignition Edge website. Everything there including Gateway setting, we put it default.
  3. After we clicked Designer button, we able to download the designer.jnlp file.
  4. The login interface pops up as well after we clicked on designer.jnlp file.
  5. Things went wrong hereafter we insert the username and password. After we clicked the log in button, the interface closes up automatically and didn’t show up again. Task manager also didn’t show any Designer application or jp2launcher.exe processor is running.

We have tried other EPIC devices, everything is fine. So I think there is no problem with Java version or PC OS. Is that possible that the installation of this software on EPIC is corrupted during manufactoring process?

What version of EPIC firmware are you using?
What version of Ignition are you using?

Firmware is 1.5.0-b.42
Ignition Version 7.9.12
Other EPICs has the same version too.

Is there anything different about the networking setup of this EPIC vs the other?
Static IP, static DNS or DHCP?
It just seems like there is something blocking the designer from doing its job.

networking setup same with others, only the IP address different.

Have you tried downloading and running the designer from another PC or laptop?
Also is Java up to date? Or did you click ‘Later’ at some stage for the update process from designer?

Are you doing any logging of files to the EPIC? If the EPIC is low on memory or disk space, it could be stopping the designer from launching according to this thread here; https://forum.inductiveautomation.com/t/designer-unresponsive/17787

I have tried a few PCs, those PCs have the latest java version. Besides, I am not sure what is the ‘Latter’. But this EPIC is still a new unit. The Performance should be no problem as well, below is the gateway status when the login interface is opened:


There is no active designer on this Epic as well before login:

Here is the status after login:
On the first 5 secs:

After 5 secs the status went “Dormant”

Sorry, typo, I meant ‘Later’. It is a Java update option when opening the Designer launcher.

I think its time to take this to Inductive support. It does not seem to be related to the EPIC.

Ohh okay, thanks for the info.

One thing that you should double check is the firewall rule for Ignition Designer is active.
And that it is active for the Ethernet interface you are using. (Note that by default, it does not open for ETH1.)

Note also that this rule is automatically added when you turn on access to Designer.

You can not add the rule yourself, just modify it.

Thanks Beno, I have checked that too. Now dealing with supports from Ignition Automation. You can checked our conversation at here: