How can I disable PAC Control dialogs in debug mode related to timeout on TCP/IP sockets?

I am trying to debug a strategy that has a chart that accepts communications from client sockets. I start the strategy in Debug mode, and if no client is connected PAC Control displays a warning dialog:

Timeout. No response from device. Check hardware connection, address, power, and jumpers.

I click “Ignore” and the problem goes away. But it comes back in a few seconds.

The chart is in a loop calling AcceptIncomingCommunication() and waiting for a status other than -442 (which is what is returned before a client connects).

I have two questions:

  1. This is displayed with a yellow triangle exclamation which I presume is a warning. Does this halt or pause the chart, or do things keep running?

  2. Is there a way to selectively suppress warnings like this? Other applications I have worked with have a “don’t show this warning again” option, or a way to set warning levels so that expected warnings are not displayed. (I would be happy if this warning only appeared in the message viewer).

Had to reach out to the software guys for this one… hence the delay getting back to you.

  1. The chart keeps running (all values displayed in debug mode are just a snapshot at a moment in time)

  2. No, there is no way to suppress the warnings. If the purpose of the chart is to connect and gather data, it is very important to let the user know that it did not connect. Maybe you can play with the timeout duration so you don’t get so many popups.

Why would a socket timeout listening on 8082 affect the debugging on PAC Control port 22001? This doesn’t make sense.