🤔 how can I correctly configure a groov-write & groov read connection with certificate

I have a Groov view server installation windows 10 and I have done the process of generating the self-signed certificates and installing them, this has not been a problem.

Later I wanted to access a data store from node-network, I confirmed the connections using the groov-write-node node configuring all the options and I got the error:

“There is a problem with the SSL public certificate for the target device. It may not be installed in this device or it may not match the private key in the target device. Error code: DEPTH_ZERO_SELF_SELF_SIGNED_CERT”.

I would appreciate your input on how to resolve this error.

Information:

Without Certificate:
Configuracion Sin

With certificate .pem

:thinking:
According to the article, for local installations of groov-view and node-red on the same device they don’t need the certificate, but I have done it both ways with no positive results.

Data Store config:
image

Posts are disappearing quicker than I can reply (grin)!!!

1 Like

Sorry, @Beno I was trying to organize the post to make it clearer. :blush:

Hey @Maser sorry for the delay, was on a call to Australia…
I had to smile at the posts coming and going and really appreciate you getting your post in order.
Bottom line, welcome to the forums!

I am assuming the Node-RED is also running on the same Windows PC as the groov Server for Windows? Sounds like it is, but just want to be sure.
That’s how I run it here both at home and at work, so hopefully we can get you going.

First up, I guess something is already on port 443? And so you changed it from the default 443 to 444?
Have you tried putting 127.0.0.1:444 in? Some PC’s don’t like ‘localhost’. Also some PC’s don’t like 127.0.0.1,. so try putting its IP address in, mine is 192.168.1.22… so give that a go (with :444 in your case).
Are you able to hit the groov View mode on port 444? ie, sanity check its working on that port.

Ok, after testing that. You should not need any certificates at all. I never generated or put any in when I am running on Windows, so I don’t think any sort of self signed is required in Node-RED for the GS4W since both are running on the same PC. I’d remove any you have (I see one screen shot with none, so stick with testing the IP with no certs).

image

image

image

Looking at all those, we are very close, just the port and ‘localhost’ is different.
Lets know how you get on changing the groov Address…

2 Likes

voila!,

I have managed to start groov on port 443 by default, and by performing the configurations without certificate I have obtained good results.

Thank you! @Beno

I will try setting up the above exercise and running groov on a server other than node-red and will report back.

2 Likes

Fantastic!!
Thanks for letting us know.
It’s pretty easy to get going when its all on the same PC, glad you got it going smoothly.