I’m upgrading some equipment from Pac hardware to Groov hardware. Everything works fine except the serial input from one of four devices is not coming in properly. The data comes in formatted properly but the values are all wrong. For example character 62, right arrow, comes in as 176 and character 32, space, comes in as 235. I’ve tried changing ports on the module, resetting I/O, changing several things on pac project, changing communications handle settings, and a few other things but nothing seems to fix the issue. Note this stream is being accepted without problems on a pac serial card. Does anyone have any ideas?

RS232 or RS422 or RS485?
Also what baud rate?
You say its working OK on SNAP SCM module, but when you move it to the EPIC serial module, it mostly works, but getting some bad values now and then, or bad values all the time? Always the exact same bad values?. Only on one of the three serial ports on the EPIC, the other three are 100% Ok?
Are the other three devices the same and wired the same?

Using RS232 at 9600 baud. Parity none, data 8, stop1. All setting are the same as the pac module.

The other three devices are electronic balances, also rs232.

The input I am having problems with is from a mass spec. It is a comma delimited serial stream. The beginning of the message is ‘>>space’, followed by the time and then followed by the actual data. The data stream can be up to about 100 characters long. I was initially trying the input on channel 1 of the serial module. I moved to channel 0 and got the same result.


You mentioned SNAPPAC hardware to EPIC, What PAC version? What module firmware version? (should be 1.6f) was the specific channel wiring re inspected for any open ground shield wire? just the basics.

Running pac version 10.4 on old pac hardware, 10.5 on new groov.
The module firmware is up to date. As is everything else on the groov/epic.
Tried a new temporary wire just to check for wire problems. Get exactly the same result.

UTF8 ascii string? are you using strategy or nodered to read it?

I think it’s utf8, extended ascii.

Reading through a strategy.