Groov RIO VPN no accepting tcp-client

Good day,

I am trying to establish a VPN connection from the RIO to my VPN sever.

I have achieved this successfully with my PR1’s, talking to the server when configured as a tcp-client.

I have tried to configure same on the RIO however when I configure it as such the setting option returns with a “invalid value” and will not let me set up the RIO as a tcp-client.

Has someone else experience this by chance or is this a bug ?

I am running firmware 3.5.0-b.46


Are you using OpenVPN?
Do you have the config file from the VPN server and are you applying via the VPN configuration section in groov Manage?

Hi Beno,

No, I actually have it working on the PR1 using Softether.

I setup the connection manually, not using the configuration file. Only difference being that when I try and choose the settuing for tcp-client vs udp it lets me vs the RIO returning invalid value.

I am setting the VPN up through the Groov Manage yes.

I’ve not used tcp-client and there might be some subtle differences between the networking setups between EPIC and RIO.
Please reach out to our support team and raise an issue with them.
Lets know in this thread what you find out.

Hi Beno,

Managed to get it up and running after some struggles.

Not using tcp-client though, running the OpenVPN protocols and ports to my server with SoftEther clone server for the UDP side.


1 Like

FYI, It’s best to use UDP for OpenVPN anyways. It’s never a good idea to tunnel TCP connections inside TCP connections as it will create retransmit storms since the outer and inner packets will require retransmitting.