Groov RIO OPC-UA Port

Good Day All, I have a groov RIO, firmware version 3.4.1-B.62. I need to change the OPC-UA server port from 14840 to 4840. Our secured network only allows predefined ports and 14840 is not one of them. No matter what I do, the OPC-UA server port cannot be changed in groov Manage. Any help would be much appreciated. Thank you in advance!



Give me a little bit of time to do some testing and asking around on this one…

Port 4840 is used by Codesys.
Are you using that control engine on your RIO?

@timothy.vertin got back to me via email that they are not using Codesys, so port 4840 is available for use.

Knowing this, I first connected from prosys (OPCUA test client on my Windows PC on the same network as the EPIC with the native data server configured to use OPCUA) to the EPIC on port 14840 to get a sanity check. All worked as expected.

Then I added a new endpoint. and changed the prosys end point and it worked as expected.

Now, before we get all excited, I am not sure about the certificate in use.

Also, worth noting that this only works because the EPIC has port 4840 open to ETH0.

Its open on both UDP and TCP, I don’t know what OPCUA uses.

Bottom line, it works, but Im sure you will want to tweak things for your network setup.

@timothy.vertin Did you get a moment to do a rough proof of connection using this information?
I’m really interested to know how it works on your more constrained network.