Groov Node-RED tcp input

Is there a firewall on a GROOV-AR1-BASE that might be preventing a remote connection to a tcp node running on its Node-RED server?

I created a test flow on the groov with just a tcp input node set to “Listen” on port 8000 (server). On my laptop I’ve tried connected to it on that port (using a couple of terminal programs) but it fails. I’ve also tried other ports like 4000 and 11000.

Alternatively, I have tried setting the tcp input node to “Connect” to my laptop (client) and that succeeds.

I’ve got a copy of Node-RED on my laptop and it doesn’t have this issue.

Will Node-RED on the groov not accept incoming tcp connections?

Yes, the AR1 has a firewall, and unlike the EPIC there is no user access to it.
(How comfortable are you with Linux command line?)

I’m not familiar with Linux so not very. What would be involved?

Any alternatives like HTTP or are there any open ports I could use? It’s not as big a deal in my case, I can use it as a client, it’s just there may be multiple connecting devices and I don’t want to have to create a tcp node for every one.

Perhaps MQTT would be an option you could look at?
You can publish and subscribe to messages (tags) from a broker and you don’t need to open any ports as everything is outbound.

1 Like

Thanks, I’ll look into it.

Were you implying before that I could have access to the firewall if I accessed the command line?

That’s one backdoor option.
A better option would be to look at the EPIC PR1 processor.
It has Node-RED and full firewall access with no Linux command line required.

1 Like

Hi Beno, I will need more information about that AR1 backdoor.