Groov Epic bad communication with I/O Unit


I had to change the IP address of my Groov Epic. This Groov Epic has one I/O Unit plugged on its rack, and had a program that was running when I changed the IP. In Pac Control I changed the IP of the control engine as well as in the Groov Epic, then I restart the program and it was running.

The day after, I saw that it was not running well: the program was running but no signals from the I/O Unit. Then I saw that I also need to change the IP in the I/O Unit in Pac Control (it’s plug on the same rack as the Groov Epic but why not). I did it, I started debbug mode, then I saw an error of communication with the I/O unit. It was disabled because of too many failures in the attempt of communicate, so I enabled it again in Pac Control and the program was finally running, and I saw signals with the I/O unit.
Perfect, I unplugged the Groov Epic from my laptop and plugged it back on the network. But now, the Groov Epic is not communicating with the I/O unit again. The weirdest thing is that in the I/O page on the screen of the Groov Epic I’m able to see values that measures the I/O unit from signals, so there is kind of communication between them, but when my program is supposed to activate an output of the I/O unit, nothing is happening, no activity lights on the I/O unit.
I tried to find a place to enable the I/O unit on the Groov Epic screen but I don’t find any.

For now, I can’t connect to the Groov Epic by the network with my laptop because of an internal changes.

So help please, what’s happening!

Hi @Alexandre.Pasquereau, I just want to make sure, your I/O unit is on the same rack as the groov EPIC (not a separate I/O unit, right?). If that’s the case, the IP Address of your I/O unit can be set to “Local (loopback)”



Yes it’s on the same rack.
Okay I saw this option I was going to check it but when I read the help I was not sure it was for that.

Well, that fixed the problem, thanks so much!
I was starting to go crazy