**FIX: SQLITE node-red node not working with latest firmware


#1

**** This is at your own risk. I don’t support any accidents or screwups. I am sure Opto22 support won’t either, as this is using SSH.

The latest firmware doesn’t install node-red sqlite node/package properly. (On 6 different EPIC units)

After you install it, in the node info in pallete manager you will see this error line:

  • Error: Cannot find module ‘/home/dev/.node-red/node_modules/sqlite3/lib/binding/node-v48-linux-arm/node_sqlite3.node’ (line:4)

If you already have it in your flows, you will not be able to disable or remove it.

Here is the process that I have figured out to get it working. It does requite SSH access, using scp to upload node_sqlite3.node.

Download the file here:
I have verified this file is safe, but this is at your own risk. It did go through the google antivirus
https://drive.google.com/file/d/1CLeyX0lgZRfNHn000d6cMaeqpmsbl-jV/view?usp=sharing

1 a) Install sqlite using pallette , then either reboot or goto step 6, then come back to this after step 9
b) Using winscp (there are other ways to upload, this the way I am doing it at this time) copy node_sqlite3.node to your user directory
2)SSH into your groov box
3)Type or Copy/Paste: sudo cp node_sqlite3.node /home/dev/.node-red/node_modules/sqlite3/lib/binding/node-v48-linux-arm/.
(It will ask for your admin password, type it in and continue)
4)Type or Copy/Paste: cd /home/dev/.node-red/
5)Type or Copy/Paste: sudo npm install sqlite
6)https://YOUR IP ADDRESS/manage/local/node-red
7)In this screen, click DISABLE
8)Once the status is stopped, click ENABLE
9)Wait for about 10-15 seconds, then click on “Open Node-Red Editor”

Now sqlite is installed.

**** This is at your own risk. I don’t support any accidents or screwups. I am sure Opto22 support won’t either, as this is using SSH. But guys… Opto22 Support, please check this out and see if you can come up with a solution. And maybe, just maybe include the Opto PAC/Groov Nodes by default.

I made a copy of the /home/dev/.node-red/node-modules directory, then restored my unit, copied that directory in, restarted Node-Red, and voila there were my modules in the palette. To be fair, I didn’t check to make sure they were all working, but it seemed a start in the right direction